Closed Bug 216501 Opened 17 years ago Closed 16 years ago

Ability to pick and choose file associations when setting as default browser

Categories

(Firefox :: Preferences, enhancement, P2)

x86
Windows XP
enhancement

Tracking

()

VERIFIED WONTFIX
Firefox0.9

People

(Reporter: moz.n1, Assigned: mconnor)

References

Details

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030816 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030816 Mozilla Firebird/0.6.1+

Firebird, when set as default browser, steals file associations for .jpg, .gif,
.png, and also registers itself as default editor for .html

Mozilla gives option to de-associate image file associations, but firebird
currently does not. There are a lot of newbies on mozillazine complaining about
this. An example:
http://forums.mozillazine.org/viewtopic.php?t=20281


Reproducible: Always

Steps to Reproduce:
1. Download firebird
2. Set as default browser


Actual Results:  
All image filetypes are defaulted to open in firebird, and .htm files are
defaulted to be edited in firebird, with no option to revert it.


Expected Results:  
Firebird should ask before associating image filetypes, and not register itself
as a .html editor
I noticed this bug too. Marking NEW.

By the way, its not a dupe of bug 131106, but it is related.

This is a really bad thing. Not only can you not de-associate, but you can't
associate extension by extension.

Recommended:
Change "Make Default Browser" button to one that brings up a dialog with options
similiar to what you see on Mozilla.

If this is still a bug when Firebird becomes Mozilla Browser, we'll never hear
the end of it. It'll be a real embarrassment.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Netdragon at mozillazine wrote:
> You should always mention another similiar bug if you know of one and 
> explain why its not a dupe in your bug report, otherwise people will 
> dupe it and waste your time and theirs.

I know of bug 131106 that pertains to mozilla. It says setting as default
browser should not claim image file extensions without asking. But Mozilla does
offer a way to revert that, and firebird does not, so this is not a dupe.

I can confirm this bug.
Bug still in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030817 Mozilla Firebird/0.6.1+
Even thou I use an image viewer I can reset my file associations , some user do
not know how to.
*** Bug 216416 has been marked as a duplicate of this bug. ***
Default Editor is bug 176096
Depends on: 176096
-> me, remove bogus dependency, since that bug is specific to registering as an
HTML editor.

Having UI to reset file associations isn't really needed.  However, we do need
to give users an initial choice when making this change.  WinZip, for example,
provides a list of supported filetypes and allows you to deselect any you don't
want.  The default behaviour should stay from a basic user perspective, anyone
using image viewer programs will usually be smart enough to not let another app
steal those associations.

Assignee: blake → mpconnor
Component: General → Preferences
No longer depends on: 176096
even internet explorer (gag) doesn't steal image associations.  images open in
microsoft's image viewer, not the browser.  i think that the image assocations
should stay as they are on the person's computer by default, since that is what
the user expects to happen.  or rather, since the user doesn't expect them to be
changed.
er, maybe not on XP, but on my 2k box its always been IE by default for images.
 And it was the same for 98SE before that.  If the rough sketch for the dialog
in my head is practical, we could default to not take image associations on XP,
but to take them on other platforms where IE is the default.  People used to IE
opening images will think it odd if Firebird doesn't follow that convention.
Summary: Ability to pick and choose file associations → Ability to pick and choose file associations when setting as default browser
If you're doing it to take it away from IE, then it should check to see if IE
already has it.  Stealing it just because IE might have it isn't helpful.

Severity shouldn't be major, should it?
Completely agree with comment 9

When someone does a "make default browser", firebird should steal all file
associations that are currently with the default browser (i.e. Internet
Explorer), and leave alone all file associations that are handled by other
applications.

That would take care of not stealing images, html editor, etc if you have better
applications installed for them.
But there does need to be some way to take those other associations in case
someone does desire them to belong to the browser.  

So a dialog with an expandable checklist
[ ] HTML
   [ ] htm
   [ ] html
   [ ] shtml
   [ ] shtm
[ ] Images
   [ ] png
   [ ] gif
   [ ] jpg
   [ ] bmp
   [ ] mng ;-)
[ ] XML
   [ ] xml
   [ ] xul
[ ] XPI
This is clearly important to many users, as well as providing an FYI on the
changes.  I suggest this be added into a "Custom Install" (or should it be
regular install?) mode of the future installer.

Also, what does someone higher up the command chain think about making this bug
block bug 215093 (1.0 Feature Development Tracking) and bug 214263 (Windows
Installer)?  The ability to set this at install time is important for the
installer when it becomes available, and I don't think this should be absent in 1.0.
Re comment 10: How do you propose to do that?  How do we know which programs are
browsers and which are not?  We will not be keeping a list of known browser
names.  I suppose we could do it like this: if(current http exe==file type
exe){file type exe=Firebird;}
Known Browers we wanna piss off:

Opera
IE

Do we need to know any more?

We could just break it down to 
[ ] Web Files
[ ] Image Files

Just as long as I can tell it to stop stealing image file associations I'll be
happy. 
Depends on: 206618
+---------------------------------------+
| Please select the types of files that |
| Firebird should be used to view.      |
|                                       |
| [-] Web Documents                     |
|   [ ] HTML (*.html,*.htm, *.shtml)    |
|   [ ] XHTML (*.xhtml)                 |
|   [ ] XML (*.xml, *.xul)              |
| [-] Image Formats                     |
|   [ ] JPEG (*.jpg,*.jpeg)             |
|   [ } PNG (*.png)                     |
|   [ ] GIF (*.gif)                     |
|   [ ] BMP (*.bmp)                     |
+---------------------------------------+

I'm thinking something along the lines of this for UI.  On Windows XP, the image
formats should NOT be selected by default, as by default it is set to the
Windows Image Viewer, and we don't want to hijack that association.

On earlier versions of Windows, however, IE defaults to own those image formats,
so it make sense to default those on for those operating systems.
QA Contact: asa
Would this UI also be available somewhere in tools->options->general or
tools->options->advanced ?

If someone sets some file associations while "set default browser", and then
wants to change associations later, it should be easy to find.



I don't think that's needed independently in the UI, although if we're going to
have a visual indication that its the default browser, the button that allows
you to set as default browser could be "Show File Types" or something equivalent.

This just keeps growing and growing.
"Set default browser" button spawning up the UI in comment 15 sounds good to 
me.
I think Firebird should not be stealing associations for graphics, at least not
on Windows when better alternatives are available (editors, Microsoft's preview
app etc)... XML is tough, I'd say "no"... the web documents for sure. 

The complicated configuration UI presented above is not necessary. Users wanting
fine control over associations can just use Windows to do it. 
Ok, so just htm, html, xhtml, shtm, shtml ... am I missing any?

Make it so, Mr. Conner.
simple. i like it.

Should I change the summary from:
"Pick and choose file associations when setting as default browser" 
to
"firebird should not claim image file associations when set as default browser"?

HTML editor bug 176096 is already fixed, so that is no longer a concern.
perhaps when making phoenix the default browser, the behavior should simply be
to take the web page files (not image files) and then, separately, in the
advanced preferences, you can have the ability to associate different files with
phoenix or change the prefs back to windows default or whatever.

this would take care of stealing the image assocations, making the "set default
browser" simpler for the newbie user, and also give the more experienced users
the ability to easily change associations they care to change.  i don't know
what you'd call the bug in this case, though, since it sounds like it should
become two different bugs.
I agree with the above, #22, but with the proviso that the custom install has a
dialog on the lines of:

[*] HTML
   [*] htm
   [*] html
   [*] shtml
   [*] shtm
[ ] Images
   [ ] png
   [ ] gif
   [ ] jpg
   [ ] bmp
   [ ] mng ;-)
[ ] XML
   [ ] xml
   [ ] xul
[ ] XPI

(Stolen from alanjstr)

The web formats selected by default, while the images are not.  This way if the
user doesn't want Firebird the default viewer for images, they simply click past
the dialog, and if they do, they don't have to go hunting through the ui after
install.

It would still be needed somewere in the ui though, in case another program
steals the associations after Firebird is installed.

I know you can do it through windows, but that's a much more time consuming method.
Ben, how about if the File Types dialog is available where the button for "Set
Default Browser" is currently?  Its not complicating the UI unless people go
looking for it, and we don't have to launch the dialog when initially setting as
default.  IMO, the Windows File Types interface really sucks for ease of use for
normal users.

IMO - since the button says explicitly "Set Default Browser" it either should
not touch any file types that are not Web/XML files or the title should be
rephrased (e.g. "Associate(d) Filetypes...")

bug 131106 has somewhere in the comments a fairly nice algorithm for finding out
what files to take over:
  1) Take over web files (htlm, xhtml, xml, etc.).
  2) Image files Mozilla supports that are not associated should be taken over.
  3) Image files Mozilla supports that were associated to the previous web files
     handler (IE, Opera, whatever...) should be taken over.
  4) Leave the rest alone!

That should not require any prompts or confirmations from user except the
agreement to make FB the default browser and still keep regular Joe user happy,
since no files that were not previously handled by browser are now hijacked
unless there were no previous associations...

Voting for this bug to be resolved asap.
Sounds pretty reasonable. That, along with an ability to fine-tune the choices
should be good.
> Users wanting fine control over associations can just use Windows to do it.

Windows is inadequate for doing this. Its a lot simpler to just check/uncheck a
series of checkboxes than to look through the mile long list of file types, make
sure that we associate it correctly, have to find the icon, etc. As a Win32
user, I expect the applications to provide this functionality because its not
adequate. Most professional applications do it, so its probably expected by
everyone. That is a separate bug, though.
An "Associate with Firebird..." button could bring up the dialogue described in
comment 15, with the addition of a "Use Firebird as default web browser" button
or checkbox at the top.

My Windows XP has *.jpe registered as a JPEG file type; maybe it should be
included as such.
Greg: I'm mentioning this in Bug 99830 since its about changing the association
icons, has a patch, and will affect nsWindowsHooks.cpp

http://lxr.mozilla.org/seamonkey/source/xpfe/components/winhooks/nsWindowsHooks.cpp#85
Sorry, I typoed. Bug 99380 - Different shell icons to identify each associated
file type
Attached patch patch (obsolete) — Splinter Review
works, it'd be nice to have some testing and feedback on it, still need to
check some of the licensing stuff out, but I would like some people to give
this a test run
Attached patch patch with proper licensing junk (obsolete) — Splinter Review
a note on the UI, as discussed, the initial feedback occurs, after which on
subsequent visits to the General pane, you have the option to directly edit the
file types Firebird handles by default.
Attachment #132827 - Attachment is obsolete: true
Can you attach screenshots?
found a minor glitch, new patch coming up once my build finishes

http://members.rogers.com/mpconnor/images/button-pressed.png
Visual feedback on clicking to Set Default Browser

http://members.rogers.com/mpconnor/images/dialog.png
Different UI assuming we are still set as the default browser, clicking the
button yields the dialog shown (UI based on original seamonkey code, we can
always make it more like a tree later)

The important thing with this is that it keeps the original ease of use for
setting as default browser intact, while allowing for people to go back later
and add/remove settings.  It also lets us fine-tune what filetypes are on by
default.  (The current patch does not take any image format patches.)  There's
no additional UI by default, and it replaces useless UI (after you set as
default, that section gives nothing to the user) with something that people may
want.
Severity: major → enhancement
Ok, so I click the button, it turns gray and a dialog pops up asking about file
formats and protocols.  And then after I click OK, or Cancel, the button goes
back to being black, right?  

The Set as Default button should not be disabled, since someone may come back
and decide to check or uncheck a box at any time.

I do not think that Chrome should be listed.  Also, if Chatzilla is installed,
is there a way to add irc: to the list, or is that thinking too far ahead.
I'm not sure if there's an easy way to add irc:// as I don't know if winhooks
has this hooked up in the backend.  I could always delve into winhooks, but its
orphaned and unmaintained for the most part, so we'll cross that bridge when it
comes to it.

And the dialog will only be available after you set as default browser, not
immediately.  This would be trivial to change, but I was trying to comprimise
between the simplicity of the current "set as default" and the ability to change
filetypes after the fact, as I alluded to in comment 24.  Sane defaults and the
ability to change later is a vast improvement to what is current, without
bogging down those who just want a simple button.

Status: NEW → ASSIGNED
How about two buttons? - "Set Default Browser" (grey when Firebird is the
default browser), and "Advanced..." - people who only wanted to make Firebird
the default browser would just leave "Advanced..." alone; anyone interested can
tinker immediately - no need to leave and come back.
its UI clutter, since you'd have buttons present that aren't useful at certain
times.

The only other combination is to convert the second deck (after the "Set As"
button is clicked) to have the button for setting file types, so clicking again
gives you the dialog, I don't think the dialog should appear by default.

There may be a useless button at some times, but a one-button system leaves more
whitespace in the dialogue box, which is just as much use as a greyed-out button
- I don't think it's a disadvantage.

Alternatively, the "Set as Default" button could just disappear, leaving only
the "Advanced..." button. The words "Mozilla Firebird is currently your default
browser" would give context to the "Advanced..." button.
The biggest complaint about the current button is that it takes associations
without asking.  I think clicking the button should bring up the dialog.  The
dialog should list existing ownerships.  This provides an immediate status as to
whether FB has what you think it has.  If you want more, you select them and
click OK.  If you don't like something, uncheck it.
couldn't the dialog box have something similar to ie's script notification
popup?  that popup has a simple box that says "blah error blah" by default, but
there's an "Advanced >>" button that extends the dialog box out to include the
specifics.  in this bug's case, clicking the "set default browser" button would
bring up a confirmation box (which i believe is a good idea), and the advanced
button would then bring out the file associations if clicked.

doing this would give you simplicity for those who need it, advanced settings
for those who get cranky without it, and still leave room for the main option
window's button to turn into file associations afterwards with no ill effects,
preserving gui optimization.
a lot of well-meaning people think warning dialogs are a good idea for this or
that reason, but the reality is that we need to draw the line on warning dialogs
except for cases where there is an high risk of dataloss etc.  Changing the
default browser is very low risk, aside from changing file associations that can
be undone relatively easy.  So that idea, while technically possible, won't work.

I don't have a problem with the set as click changing to a file types button,
but forcing the dialog is a bad idea for the typical user, since the typical
user doesn't know what http:// vs. ftp:// means one iota, and they'll just click
OK to the annoying dialog.

Guys, keep in mind that those people cced on this bug (at least that I know)
tend to be power user-ish, and want more control/options/configurability.  The
majority of users, however, don't need/want this much control.  Firebird is
targeted for the average user, even including this type of configuration is a
concession to Windows power users.  It could easily be relegated to an
extension, per the "pure" philosophy, but it is borderline enough to be considered.
You're saying the dialog should have a button to show another dialog?  I really
don't think the list of items is that complicated.  
however the list is displayed, i think it should list the extensions for file
types.  so instead of "html files", it could say "html files (.htm, .html)"
Let me be clearer.  When you first run Firebird, it should pop up a dialog
asking "would you like to make firebird your default browser."  Clicking Yes
would bring up the association dialog.  HTML files would be checked, but not
GIF, as the default list of things to take over.  (Stealing it from Opera/IE is
a different issue.)  The user then clicks OK to take over the file associations
or Cancel to not make any changes.  No confirmation is needed after this, since
they just clicked OK and they already had a chance to say No twice.  

Clicking the button on the Options panel would present the same dialog.  This
time, existing ownership is displayed.  That's how ACDSee does it and I think
that's a good idea.  If the user clicks OK, then the changes are saved.  Maybe
Save is better than OK.  Again, the user has been presented with this
confirmation, so nothing is needed afterwards.  OK/Save and cancel will close
the dialog.  
I don't think the user should be presented with a list of file types on first
run - endless dialogues are far too reminiscent of Opera <shudder>. The dialogue
should say "Make Firebird the default browser? (Advanced association options are
available in the Options dialogue on the Tools menu) [Yes|No].

This gives a simple Yes/No for ordinary folk, and tells power users where to
find advanced options; the word "advanced" in the blurb would probably suggest
"ignore this if you like" to Joe Public.
I agree with Greg on dialog overload when you run applications. I also think
that "Default browser" is a bit ambiguous because most people don't even know
what a browser is (I am not joking - just go around and ask). In fact, most
people think what we call a web browser is called Internet Explorer, or just
Windows. How about "default browser of web pages"?

It should be like Greg mentioned, but with a checkbox that says "Bring up
associations dialog"

+------------------------------------------------------------+
| "Make Mozilla Firebird the default browser of web pages?   |
| (Advanced association options are available in the Options |
| dialogue on the Tools                                      |
| menu)                                                      |
|                                                            |
| [ ] Show associations dialog blah blah                     |
|                                                            |
|                 [Yes]          [No]                        |
+------------------------------------------------------------+


In the preferences box, why don't we have "File and Protocol Settings" as the
only choice, and inside the box, have the mouseover tooltips say:

HTML: "Set Mozilla as default browser"
JPEG: "View JPEG graphics in Mozilla"
etc
Oh, btw.. If we pop up the associations dialog, I think we should pop up the
preferences with it within the General pane. That way, they will see it as it
would appear if they had accessed it within preferences, and know how to get
back to it if they ever need to again.

Should we associate with Mozilla-specific file types (i.e. XUL) automatically
whether or not the user clicks Yes to the dialog? I don't see why we can't
associate with XUL and other Mozilla-only formats automatically if they are not
already taken and we handle them.
new patch coming up making the Set File Types button available after clicking
Set Default Browser button.
Priority: -- → P2
Target Milestone: --- → Firebird0.8
Attached patch patch for review (obsolete) — Splinter Review
changes mentioned in previous comment, some code cleanup stuff as well
Attachment #132852 - Attachment is obsolete: true
Comment on attachment 133024 [details] [diff] [review]
patch for review

ben, I've tried to keep this as clean as possible, wording of course is always
debatable, but the spirit of the UI change is what I'm looking for
comment/review on
Attachment #133024 - Flags: review?(bugs)
Blocks: 216432
Attachment #133024 - Flags: review?(bugs)
Attached patch patch v1.1Splinter Review
odd little glitch in that patch
Attachment #133024 - Attachment is obsolete: true
Comment on attachment 133200 [details] [diff] [review]
patch v1.1

looking for sr for the UI change
Attachment #133200 - Flags: superreview?(bugs)
Being the reporter, I would like to argue against the patch. This patch, while
being consistent with the current bug summary, is not consistent with the
mozilla firebird charter at http://www.mozilla.org/projects/firebird/charter.html

Reason: This UI would fall under the 85% of seamonkey preferences, that most
users never touch. The default should be good enough.

As per comment 19 , all that needs to be patched is the default.
images - no, xml - no, html - yes. There is no need for a UI change.

I'd again request that the bug summary be updated to
"firebird should not claim image file associations when set as default browser"
Ok, so stop stealing all images.  Leave the rest as-is.
other than rejecting it on "principle" due to a relatively ambiguous charter,
lets look at pro vs. con compared to simply implementing some visual feedback:

Pro:
Does not affect existing usage pattern (hitting set default browser and OK still
works without further intervention)
Allows for easily undoing changes from within the application in question
(Windows File Types dialog is slow and non-intuitive to use, assuming users know
where to find it)
Reuses screen space from what would be otherwise useless UI once default browser
is set (something useful instead of something useless)

Con: 
Adds a potential to complicate things if people double-click (if they click OK,
, no harm done)
Small increase in code footprint, including new dialog .xul file included in the
build.
Violates some sacred principle of not catering to "power users"

Using that 85% rule, certificate manager, the advanced javascript preferences,
and most of the other advanced prefs should be backed out too.  Its not always a
matter of "how many people will use this" but "how important is this to the
people who need it, and what do we lose in implementing it?"

sane defaults should be enough, but that argument is good for a lot of things
with preferences, and should not be used as a blanket argument against a patch
that adds flexibility without adding to the UI (it just provides different UI
based on current settings)
I agree with vfwlkr in #54: keep it simple. Fewer potential bugs, etc.
Normally, I'd go for the power user dialog.  But in this case, I think it's
really unnecessary.  

Firebird shouldn't take image associations, even if IE has them.  Image
associations does not say "default browser" to me.  If someone really wants to
open an image with Firebird, let them set it as the image handler.  I have yet
to see someone ask "how do I make my images open in FB?"

Javascript doesn't need to be that finely controlled, either, but that's not
what this bug is about.  

I'm not sure that there really needs to be an Undo for setting the default
browser.  That puts FB on parity with Seamonkey, though, and wouldn't add
clutter if its the same button.  
I'm with Mike Conner with this: But I offer a compromise.

Compromise: Why don't we offer this as an extension that is distributed with
Firebird? I don't see why this wouldn't fit in nicely as an extension and aren't
we trying to move in that direction? The only issue being that a user who
presses "Yes" would need to install the extension in order to use the feature.
This extension would not be installed, but any power user would know how to do
it. If they click "Yes", we could pop up a help window explaining how to tweak
these settings by installing the "Advanced Preferences" extension and provide a
link in the help to install the extension, and open up "Advanced Preferences".
<offtopic>The advanced preferences extension could also have something like
about:config.</offtopic>

We need some default extensions instead of quiveling over every little UI
disagreement. Therefore: 

Web developer things like Javascript Console -> Web Developer extension
View Source -> View Source Extension
Popup Manager -> Popup Manager Extension

Why hardcode everything into the UI? Let's make better use of extensions.

This would be like "Tweak UI" on Windows -- an extension for the Preferences
that includes both this and other preferences that we don't want to confuse the
average user with?


I believe that more users would touch these preferences than people realize, and
the flipside of that is that the ones who most want this feature are those that
most often use Mozilla and Firebird (Power Users).

This browser is going to replace Mozilla Seamonkey, so it can't be so
dumbed-down that power users find it fully inadequate.

Therefore, I believe that part of the charter should be "Expected features of
power-users and existing users". Because if 85% of people use a computer once a
week, and the remaining 15% who use Firebird every day want a feature, shouldn't
the ones who use it the most get the most say? I don't believe this is useless
UI in the least degree, and this UI could be carried over to other operating
systems too, since with a few changes, you could use the UI with associations in
Gnome, etc.

As for the charter, its a charter and not a list of requirements.

The other concern I have is that Mike Conner did a good job and why just toss
what he did out the window? Its like saying his work isn't appreciated. Can't we
come to a compromise such as an extension?
The least amount of impact to the current design would be to simply remove images.  

Advanced file association management is a good idea for an extension.
Re comment 61:

At first I thought this had to be in by default and that an extension was just
relegating should-be-default stuff to optional-install.  But then again, as
mentioned earlier, current users are power users.  The users we are targeting
mostly use IE.  Such users always compare Firebird to IE, saying "IE has this,
why don't you?"  Does IE have a built-in association manager?  Nope, all it has
is a button to reset associations to IE defaults (and the little "Notify if
associations change" checkbox that's definitely UI clutter).

I now love this extension idea; such an extension would certainly be popular (my
guess is a little less popular than TBE, but not by much), at least until this
is settable in an installer.  As I mentioned in comment 12, this needs to be
settable in future versions with installers (but definitely as a Custom option).
considering that the core (useful) functions in TBE are expected to be
implemented  in FB, that's not the greatest "against" argument.

The only difference in the UI/set as process is the ability to bring up a
details dialog while taking that action by clicking again.  If you don't,
there's no change.  If you unset FB as default browser, it reverts the UI to
make it simple again.  IE doesn't have this, true, but Netscape/Mozilla/Opera
do.  Its about balance, not focusing on simplicity.

Turning this into an extension is pointless, since it means that the advantage
of having it obviously accessible is gone.  I'd rather ben look at the UI change
in action, and decide whether or not its viable.

This could all be moot soon anyway.
Moot?
Moot.  http://dictionary.reference.com/search?q=moot
If that's actually a question as to *why* it would be moot, an explanation of why?
Bug 222796 is a META bug I just filed about outsourcing current Seamonkey
features to extensions and making them available in Firebird.

We do need some way to reset the association anyway, and therefore a button
within Preferences will have to be there. Why would it be such a big deal to
carry it onto a dialog box allowing you to fine-tune? Perhaps simplicity. It
might perplex some users, but it wouldn't provide any noticeable bloat to the UI
because the reset button would have to be there anyway. If Ben doesn't want this
UI in, I suggest we could do the following:

- Make it only replace the HTML extension.
- Provide a button in preferences to only reset the extension (is this necessary?)
- Create a standard extension(s) (META bug 222796) for advanced fine-tuning
across all platforms (Windows, Gnome, etc) and Gnome does allow associations

There might be advantages to making this an extension. Other Mozilla-based
browsers could use it, for instance. Wasn't the idea to move a lot of things to
extensions? Why hasn't this been happening? Or were extensions only meant to be
3rd party? I don't see why they have to be.
See also bug 131106
Related:  bug 131106 - Make 'default browser' shouldn't steal image file
associations from image programs.  That's filed under XPApps, though.
*** Bug 224299 has been marked as a duplicate of this bug. ***
Comment on attachment 133200 [details] [diff] [review]
patch v1.1

thinking about this some more, a less power-user interface is probably needed
Attachment #133200 - Flags: superreview?(bugs)
How about just adding a set of prefs? For example, if browser.associate.jpeg is
set to true, Firebird associates .jpeg files with itself. This would work best
if the user could add a pref specifying any extension - browser.associate.* -
and have .* files associated with Firebird.

Also, Firebird could keep a record of each file extension's previous
association, so that when the pref is returned to false the previous association
can be restored.

This avoids the need for adding any new UI, as about:config is built in.
Mike: I was wondering if you could just provide the very simplest possible way
to reset the action for now (probably part of your original patch) so that we
can just get this issue off the list and perhaps open another bug for an
advanced interface for power users, perhaps extension-based?
I want to simplify this to web pages, images, and maybe that's it.

Dropping to 0.9 to rethink this.
Target Milestone: Firebird0.8 → Firebird0.9
Perhaps .swf files could be registered as well. They're usually registered by IE
or not associated at all. 
It sounds like a good idea from a usability standpoint, but since Flash isn't a
native type for Mozilla, I don't really think we can do that. Just associate
flash files with Mozilla and you are all set.
yes same for me .... I have my own icons for nearlly all ... and I have to
re-associate each time  htm html xml ........
it's really boring
a few programm asks before to feel ar home in my computer
I will not be taking any new UI code here. I will repeat part of my original
comment.

I think Firebird should not be stealing associations for graphics, at least not
on Windows when better alternatives are available (editors, Microsoft's preview
app etc)... XML is tough, I'the web documents for sure. 

*Let's just make it stop stealing image and other non-related types* That should
be a simple patch. 
ok, I'm going to spin off what we will do into a new bug, and mark this one 
WONTFIX

Bug 230922 filed to make the defaults sane.
No longer blocks: 216432
No longer depends on: 206618
Speaking as a user this time, and not as a developer, I'd like to say that
whatever can be done in the short term to make it not steal other associations
I'm all for (please only comment out the code for other associations if you go
that route). In the long term, though, I believe a UI that allows you to pick
associations of types this program handles is a lot more convenient to me than
using the Explorer interface and also allows me to undo associations I
accidentally made much faster. It is also something users like me expect in
their software. Quicktime offers it, Realplayer offers it, and most other
programs offer it.

As a developer, I believe we will be criticized for not offering the interface
by C|Net and others once Firebird reaches 1.0.

So do what's necessary for the short term to make the default association ONLY
HTML, but in the long term I hope the UI gets put in.

I don't see a reason to mark this bug WONTFIX, but I do agree a spinoff bug is a
good idea for a quick fix since this is a major issue.
You think that CNet is going to ding Firebird because it doesn't let you
associate images with Firebird?  File associations beyond the realm of "html"
can be done by an extension.

From Ben's comment: WONTFIX
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → WONTFIX
Verified. Here's hoping the extension gets made.
Status: RESOLVED → VERIFIED
*** Bug 233585 has been marked as a duplicate of this bug. ***
I've created a new bug that may be of some interest to those of you involved
with this bug, to do with choosing file associations.  It is Bug #244257.
Blocks: 282239
No longer blocks: 282239
Blocks: 282239
You need to log in before you can comment on or make changes to this bug.