Download more in spellchecker's language pull down does not work

RESOLVED FIXED in Thunderbird0.7

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: John F. Herminghaus, Assigned: Scott MacGregor)

Tracking

unspecified
Thunderbird0.7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718

When using the spellcheck clicking on "Download more" in the language box does
not produce any results.  

Reproducible: Always

Steps to Reproduce:
1. Open spellcheck
2. Click on language 
3. Click on "download more"

Actual Results:  
nothing

Expected Results:  
Opening of window such as Mozilla Cafe with a list of available languages

Comment 1

15 years ago
I can confirm this using 0.2a (20030813) on Windows XP.

Updated

15 years ago
QA Contact: asa

Comment 2

15 years ago
Three notes/necessary steps:
1.) content/communicator/builtinURLs.js is not packaged for Thunderbird. This is
why nothing happens after clicking on "download more".

2.) builtinURLs.js function needs to be adapted to open a new browser window
(currently works in seamonkey only).

3.) bug 218120 needs to be fixed in order to display the appropriate download
page (and not a blank one).

Comment 3

15 years ago
Points 1 & 3 from comment 2 are fixed now.

Comment 4

15 years ago
*** Bug 227910 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Summary: Download more in the language pull down does not work → Download more in spellchecker's language pull down does not work

Comment 5

15 years ago
*** Bug 228860 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Also seeing this on Thunderbird 0.5 under Windows XP, with the slight difference
to comment 1 that instead of seeing "nothing" a small windows (showing title bar
only) appears.

See also http://forums.mozillazine.org/viewtopic.php?t=55348

Also suggest someone add "dictionaries" and/or "dictionary" to the summary to
make this bug easier to find.

Comment 7

14 years ago
*** Bug 230686 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
*** Bug 238490 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
*** Bug 234994 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
Why hasn't this bug a target milestone?

Comment 11

14 years ago
I upgraded to Thunderbird 0.6 today with the installer. I use windows xp pro. 

Now when I pressing the Download more I get an error.

"The file /content/navigator.xul cannot be found. Please check location and try
again."
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird0.7

Comment 12

14 years ago
I get the same message using thunderbird 0.6 in linux (fedora core 2 test3).

Comment 13

14 years ago
The same with Thunderbird 0.6 on MacOS X 10.3
*** Bug 243976 has been marked as a duplicate of this bug. ***
OS: Windows XP → All
Hardware: PC → All

Comment 15

14 years ago
I have a patch for this, with one(?) issue. The patch makes the spellchecker
just launch the user's default browser rather than assuming they run SeaMonkey.
This works fine on my WinXP machine, but does this fix make sense for *NIX
platforms? I can't find a way to do any fancy #ifdef's for that, because the
preprocessor doesn't appear to run when mozilla/editor is built. The other side
effect of this is that, if for some inexplicable reason the user's default
browser is Firefox but they're using SeaMonkey's MailNews reader, when they
click "Download More" Firefox will load and downloading the new dictionary from
there wouldn't install it in SeaMonkey as the user expects.

Would this solution be satisfactory, or is there a better fix I don't know about?
(Assignee)

Comment 16

14 years ago
Patrick that sounds fine.

We'll have to fork the spell checker files for Thunderbird. These changes should
not go into seamonkey. Thus avoiding the complications you referred to.

Comment 17

14 years ago
Ok, I guess I'll hold off on posting that patch since forking that will be
non-trivial.

Also, FWIW I'm not sure where "Patrick" came from :)
(Assignee)

Comment 18

14 years ago
Sorry Jon :)

The fork should be trivial. Feel free to just post the diff and I'll fork it. 

I'm assuming you just needed to change the spell checker .xul and .js file.
That's what I was planning on doing to fix it anyway.

Comment 19

14 years ago
Created attachment 149243 [details] [diff] [review]
Patch

Alrighty. I didn't see an obvious change that needed to be made in the XUL
file, but I did put a URL into builtInURLs.rdf, as I saw was done for SeaMonkey
in an earlier bug.

Updated

14 years ago
Attachment #149243 - Flags: review?(mscott)
(Assignee)

Comment 20

14 years ago
Created attachment 150214 [details] [diff] [review]
the fix adapted for thunderbird with a forked version of the spell check JS file
(Assignee)

Updated

14 years ago
Attachment #149243 - Attachment is obsolete: true
(Assignee)

Comment 21

14 years ago
fixed on the trunk and on the branch. Thanks Jon!
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Updated

14 years ago
Attachment #149243 - Flags: review?(mscott)
You need to log in before you can comment on or make changes to this bug.