Composer incorrectly wraps <html><body></body></html> around existing html code

RESOLVED INVALID

Status

SeaMonkey
Composer
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: Julian Knight, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Composer adds DOCTYPE, html and body tags to an existing web page even when the
web page does not require them (because these tags are provided by a template
engine (e.g. PHP, ASP, etc.)

These should be an OPTION otherwise composer will only be useful for a minority
of web pages.

Reproducible: Always

Steps to Reproduce:
1. Take existing web page or page snippet (not including DOCTYPE, html and body
tags)
2. Edit in composer
3. View HTML code

Actual Results:  
HTML code is now invalid due to an extra, unneeded set of tags.
e.g:
----------------------------------------------
<?php
require_once('template.class.inc');
$Template=new Template();
$Template->title = 'Knightnet Home Page';
$Template->pageVersion = '3.0';
$Template->pageVersionTxt = 'Rewritten to use CLASS version of template';
$Template->outputTop();
?>
--------------------------------------------
Which produces correct XHTML code using PHP,
Becomes:
============================================
<html><head></head><body>title = 'Knightnet Home Page';
$Template-&gt;pageVersion = '3.0';
$Template-&gt;pageVersionTxt = 'Rewritten to use CLASS version of template';
$Template-&gt;outputTop();
?&gt;
========================================
With a DOCTYPE tag also added (which is NOT selectable) which produces:
-----------------------------------------
title = 'Knightnet Home Page'; $Template->pageVersion = '3.0';
$Template->pageVersionTxt = 'Rewritten to use CLASS version of template';
$Template->outputTop(); ?>
------------------------------------------
at the top of the rendered web page as the php code is now invalid.

Expected Results:  
There should be the option for composer NOT to add these tags so that
dynamically create web pages (and web page snippets that slot into other pages)
remain correct.

There appears to be no workaround for this issue.

Comment 1

15 years ago
Composer is a web page editor, not a template editor.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.