If displaying XML in text box, second to last node in XML doesn't display correctly if it has a dot (".") in it (ex. "</Account.List>")

RESOLVED DUPLICATE of bug 64799

Status

()

RESOLVED DUPLICATE of bug 64799
15 years ago
5 years ago

People

(Reporter: rgupta1, Assigned: harishd)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I have the following HTML and the XML data seems to become garbled.  The second
last node (if it contains a dot ".") doesn't show the full node name, but
truncates after the dot.

<form>
<textarea name="RequestData" rows=20 cols=80 wrap=virtual>
<Document>
<AccountList.GetList>
        <Actor>MOS</Actor>
        <TaxID>111320001</TaxID>
                <Filter>
                        <DlrNbr></DlrNbr>
                        <ExpressNbr></ExpressNbr>
                </Filter>
                <Pagination>
                        <StrtIndx>1</StrtIndx>
                        <NbrOfRows>5</NbrOfRows>
                </Pagination>
</AccountList.GetList>
</Document></textarea> 
</form>

In this HTML, the "</AccountList.GetList>" shows as "</AccountList>".  It
happens consistently with other similar XML documents displayed in a text area.

Reproducible: Always

Steps to Reproduce:
1. Put the above mentioned HTML into a .htm file and load it.  
2.
3.

Actual Results:  
As reported, it doesn't how the </AccountList.GetList> but just shows as
</AccountList>

Expected Results:  
Should have shown as </AccountList.GetList>
This is an HTML parser bug, reassigning. Also I am pretty sure this is a
duplicate report.
Assignee: hjtoi-bugzilla → harishd
Component: XML → Parser
Whiteboard: DUPEME
You need to escape your tags inside textareas. This was fixed by bug 64799, duping.

*** This bug has been marked as a duplicate of 64799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.