Autocomplete presents wrong options in blank textfield.

VERIFIED WORKSFORME

Status

()

Firefox
Address Bar
--
major
VERIFIED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Kevin Ar18, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030810 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030810 Mozilla Firebird/0.6.1+

This issue applies to a page with multiple textfields (all with different
autocomplete data in each text field.  If the user uses autocomplete on one
textfield and then moves to another text field and presses the down arrow, the
autocomplete options presented are wrong.  Instead autocomplete presents
whatever the last selection option from the other textfield.

Reproducible: Always

Steps to Reproduce:
1. Go to http://atwnt333.external.hp.com/bus-nacons/caller/chat_pilot.asp
2. Fill in some data in the text fields and hit the "conect" button
3. Go back to the same page again.
4. Select and use an autocomplete option on the first text field (any method is
ok, whether it be keyboard or mouse).  In other words, fill in that text field
using autocomplete.
5. Place the cursor in another blank text field.
6. Press the down arrow key.

Actual Results:  
You will notice that the option that autocomplete gives you is the same data as
what you filled in in the previous text field.
You can repeat this process on other textfields and it will show the same data.

Expected Results:  
Autocomplete should have showed you the options available for the specific
textfield.

Comment 1

15 years ago
I found it to be "moody"; sometimes I'd get the correct data, sometimes the data
from the last filled line.

-->Confirmed
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
Works for me, 20031029 Firebird/0.7+. Kevin, could you please try one of the
latest nightly builds and see if it's fixed for you too?
(Reporter)

Comment 3

14 years ago
It sure, has.  Thanks for the info.

Works on:
Mozilla/5.0 (Windows; Windows NT 5.1) Gecko/20031023 Firebird/0.7+
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 4

14 years ago
...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

14 years ago
WFM
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 6

14 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.