browser opens a new window on linked Winrar files.

RESOLVED DUPLICATE of bug 173175

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 173175
14 years ago
a year ago

People

(Reporter: Robert Schulz, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

When I click on a .rar file type instead of the download manager handling the
file download a new window opens showing it's contents.

Reproducible: Always

Steps to Reproduce:
1.Find a .rar file to download
2.Click the link
3.Then new window opens instead

Actual Results:  
Mozilla open a new window displaying the file contents

Expected Results:  
Download manager should of handled  the link
(Reporter)

Updated

14 years ago
Summary: browser opens a new windows on linked Winrar files. → browser opens a new window on linked Winrar files.

Comment 1

14 years ago
Can you post the URL of the site you are having problems with.
It sounds like the web server is telling mozilla to display the files instead of
downloading the files.
(Reporter)

Comment 2

14 years ago
Setup a sample web page

Comment 3

14 years ago
The server sends the file with a mime type of text/plain . This tell mozilla to
display the file in the browser(as text).  This is a problem with the web server
and not mozilla.

Comment 4

14 years ago
Test page is gone. If the server still serves rar-files as text/plain, the
Product should be changed to Tech Evangelism. If not, the bug could be closed.

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 173175 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.