If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Using the term Alternate Text for Alternative Text is wrong

RESOLVED INVALID

Status

SeaMonkey
Page Info
--
trivial
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: aleksr_si, Assigned: db48x)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; sl-SI; rv:1.4) Gecko/20030701
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

In Page Info -> Media, there is a field called Alternate Text
(en-US.jar/locale/en-US/navigator/pageInfo.dtd: entity mediaAlt and
mediaAltHeader, and also in Firebird, in
en-US.jar/locale/en-US/browser/pageInfo.dtd AND
en-US.jar/locale/en-US/navigator/pageInfo.dtd, the same entities).


The term 'alternate' means every second one, which is quite different from
alternative.

-------------
To quote Eric Partridge in Usage and Abusage: A Guide to Good English, Third
Edition, 1999:
alternate and alternative. The first means 'every other'. Alternate days are
Monday, Wednesday, Friday ... The related adverb is alternately, meaning 'by
turns'. 'He walked and ran alternately.' Alternate cannot replace alternative,
which means 'available instead of another', as in 'We took an alternative
route.' The adv. of alternative is alternatively, 'offering a choice'. 'You
could fly, or alternatively go by sea.'
Alternative has been overused in official jargon, in such contexts as
'alternative accommodation', 'make alternative arrangements', 'find alternative
employment', where it is often better replaced by other or new. But there is no
really satisfactory synonym for the more recent sense 'nontraditional, offering
a substitute for the conventional thing', as in 'alternative medicine',
'alternative cinema', 'alternative technology'. In this sense, it is a vogue word.
-------------

The first paragraph is what is important. The text displayed when the image
cannot be loaded is not something in turns or every other, it is simply
something that can be used instead of the image (which goes perfectly with the
Oxford WP dictionary:  alternative  /O:l"t3:n@tIv/  adjective (only before a
noun) that you can use, do, etc instead of something else).

Hence, I reckon alternate text should become alternative text.

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
Webster's Revised Unabridged Dictionary, © 1996, 1998 MICRA, Inc.:

"alternate

\Al*ter"nate\ (?; 277), n. 1. That which alternates with something else;
vicissitude. [R.]

2. A substitute; one designated to take the place of another, if necessary, in
performing some duty.

3. (Math.) A proportion derived from another proportion by interchanging the means."


Look at definition No. 2.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 50511 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
Total screwup. Sorry.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

14 years ago
This doesn't appear to be a dupe. Tempted to confirm, but the W3C standards
(http://www.w3.org/TR/html4/struct/objects.html#adef-alt) use the term
"alternate text". Wrongly, IMHO, but not sure which has the greater value,
correct English or using the same terminology as the standards document.

Comment 5

14 years ago
I've always called it "alternate text", but I notice that there are slightly
more hits on Google for "alternative text".  Hixie has said "alternate text" on
32 bugs, "alternative text" on 16 bugs, and "alternatative text" on 1 bug.
(Reporter)

Comment 6

14 years ago
Granted, the W3C uses "alternate text" in some cases, but it uses alternative
just the same -- particularly the Web Accessibility Initiative websites seem to
favour alternative. A simple Google search of "alternative text" versus
"alternate text" on the W3C website shows that the former is used 698 times,
whereas the latter merely 401 times.
Certainly, a Google search is hardly conclusive 'evidence' on proper usage,
however it shows an inconsistency in standards themselves ...

As for Webster's dictionary, yes, I realise it allows for using alternate
instead of alternative. This is, however, North American English only, as stated
by both the Compact Oxford English Dictionary and the Concise Oxford Dictionary
(the latter being the authoritative (well, it is most widely acknowledged)
dictionary for English, particularly in Europe). The former makes the following
note: "The use of alternate to mean alternative (as in we will need to find
alternate sources of fuel) is common in North American English, though still
regarded as incorrect by many in Britain."
I understand the language of Mozilla is US English (en-US), however since most
people do not bother installing a British language pack, I suppose it is a good
idea to use a term commonly recognised by speakers of all forms of English.
Besides, the meaning of alternate as alternative is only secondary in Webster's
dictionary, too.
Let's go with "alternatative text" then. :-P

Seriously though, whichever is fine by me. I would recommend asking Susan Lesch, 
the W3C technical proof reader, what she would recommend, as it is her wording 
that will be used in future specs.

   http://www.w3.org/People/Lesch/
   mailto:lesch@w3.org
Complain to w3c, and even if they did change it, "Alternate Text" would probably
remain as the de-facto standard.

http://dictionary.reference.com/search?q=alternate

al·ter·nate    ( P )  Pronunciation Key  (ôltr-nt, l-)
v. al·ter·nat·ed, al·ter·nat·ing, al·ter·nates
v. intr.

   1.
         1. To occur in a successive manner: day alternating with night.
         2. To act or proceed by turns: The students alternated at the computer.
   2. To pass back and forth from one state, action, or place to another:
alternated between happiness and depression. 


This does apply if you have images turned off. You are switching to an alternate
representation (text). Alternative would mean you have some choice over what the
representations are. You only have a choice to alternate the representations,
not over what they are, which is at the discretion of the webmaster.

We have more important things to do than quibble over English on standards on an
internationatlized browser with many much bigger issues. I hope this bug was
meant as a joke.

INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

14 years ago
I should think that it is important to utilise one's language as is deemed
correct. No sooner will one diverge from standard use than one will find oneself
misunderstood, misinterpreted and, finally, cast out from being a speaker of
English, rather forming a specialised branch of language.

Thus, be it as it may, an internationalised browser should not allow for such
misuse of wording; even more, it should strive not to do something such akin,
for an error of this sort could very easily creep into localisations other than
American English, spreading further improper usage.


To quote a dictionary as you have done is scarcely an argument -- for what you
have done is a matter of begging the question. Of course something is alternate
if it is alternate!
The problem is, still, that images and alternative text do NOT alternate, not
even when using the word as a verb. Alternative, on the other hand, does not
necessarily mean giving one a choice of something (this is what the noun and the
adverb mean exclusively), but rather something which is available for use if the
use of something else is not desired (Cambridge Dictionaries Online:
alternative: An alternative plan or method is one that you can use if you do not
want to use another one). In fact, all American dictionaries should give a much
similar definition, such as this one provided by WordNet: necessitating a choice
between mutually exclusive possibilities.

To alternate, on the other hand, means to spell: The two sentries spelled each
other (or alternated or took turns). It is absurd that this should mean to view
either images or text as though these were constantly taking each other's place.


Despite what you might think of the importance of using correct English (or any
other language for the matter), and regardless of however many other issues you
deem more important than this, the question at hand is hardly invalid.
Hence, I shall try to contact Susan Lesch as advised.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.