Single quote (apostrophe) in saved query name causes problems

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
6 years ago

People

(Reporter: adrianne.hersrud, Assigned: justdave)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Create a query, and name it xyz's.  You can re-run the query perfectly fine. 
The problem occurs when you click on the Generate Bug Report link.
The link invokes this:   <a href="javascript:openWindow( 'buglistreport.cgi?[%
urlquerypart %]' );">Generate Bug Report</a> &nbsp;&nbsp;

I am using Bugzilla version 2.16.2

Reproducible: Always

Steps to Reproduce:
1. Create a query, names xyz's
2. Run the named query
3. Click on the 'Generate Bug Report' link

Actual Results:  
Javascript error, nothing happens in mozilla.  In Explorer, when you hover over
the link you see the javascript error triangle, in the lower status area.  Same
thing happens when you click the link.

Expected Results:  
Bug Report Window appears.

v. 2.16.2
There is no "buglistreport.cgi" in the Bugzilla distribution, and we don't use
javascript popups anywhere.  You're using a locally modified copy of Bugzilla,
and it looks like your modifications are at fault.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.