Blank emails appear in my inbox listing

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Alan Williamson, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Using Thunderbird to read email from my Exchange5.5 server while on the move.  I
have noticed a number of problems with this, which have already been reported
under the MailNews product, but not Thunderbird.  Should i report them here as well?

This one i couldn't find in the bug list.  When reading emails from Exchange i
have one email that i cannot get at.  It has the header but when i click on it,
the bottom pane just continues to display the previous email.  The email still
exists on the server and I can read it perfectly (its just text) with JavaMail
and also Outlook.  Thunderbird refuses to read it.  It did at one point, but the
body has been lost.

In addition to this, i sometimes get an email popping into my inbox that is
dated 1969!  Seems to be related to the problem.

Reproducible: Always

Steps to Reproduce:



Expected Results:  
There appears to be no SOLID feedback on what the IMAP communication is doing. 
I am constantly waiting for something to happen or not!  For example, i would
like to see that its attempting to download messages, mark messages as deleted,
etc.  But i don't have this.  For this problem, if i restart ThunderBird
(clearing it from the Task Manager) i can get rid of the 1969 email.
(Reporter)

Comment 1

15 years ago
I have discovered the steps to reproduce:

  [1] Read the INBOX (or any folder)

  [2] Click on either the 'Account Name' or an 'empty folder' in the folder list

  [3] Click back to INBOX

a new email is now sitting in the INBOX
(Assignee)

Comment 2

15 years ago
>which have already been reported
>under the MailNews product, but not Thunderbird.  Should i report them here as
>well?

No, please don't report them twice. In fact if the bug exists in mozilla mail it
should really be filed there first. Problems unique to just thunderbird should
be filed under thunderbird. Problems shared by both --> mozilla mail

Updated

15 years ago
QA Contact: asa

Comment 3

15 years ago
I am seeing a similar problem using Thunderbird 0.4 (it was in 0.3 as well)
where a blank email (no headers, no body) is always in the bottom of my Inbox.
If I click on this email the "header" pane has the headers of the last email I
viewed, but viewing the full source of the email confirms that it is blank. I
can delete this email, but when I click to another folder and click back to the
Inbox, the "blank" email comes back.

I am using IMAP FWIW.

Comment 4

15 years ago
I also have experienced this problem.  The default date of the email is rolled 
back to 12/31/1969.  All of the other emails in the folder seem fine.  I'm using 
Thunderbird 0.5

Comment 5

14 years ago
One interesting thing is that TB would say Unread:2 Total:52 (when there were 2
unread and 4 read messages).

Steps to remove that irritating message :

Move all messages from INBOX to a new folder (check if it is also created and
saved on the IMAP server). This 1969 email will not be moved. Unsubscribe INBOX
(and all its sub folders). Close Thunderbird. Open it again. Re-subscribe to
INBOX. Move the messages back.

Comment 6

14 years ago
Created attachment 152176 [details]
Example of bug

Comment 7

14 years ago
Created attachment 152177 [details]
Settings that generated the bug

Comment 8

14 years ago
Just reporting the same problem in 0.7.1.  The common thread
may be that it is a IMAP connection - at least that is
what most people use with Exchange, and that is what I am
using.  I have attached pictures demonstrating the problem
(the details in the preview pane are for the previous email)
and a picture of the servers settings.  The server is
imap-2001a-10.i386.rpm running on Red Hat 7.2.

Comment 9

14 years ago
For what it's worth, I see the same problem with Thunderbird 0.7 (I don't
remember seeing it with 0.6, but since I upgraded today, I've had it happen
to 3 or 4 e-mails).

Comment 10

14 years ago
Actually, I am seeing similar behavior in Thunderbird 0.8 under Linux using a
POP3 mail provider.

Funny, the 12/31/1969 problem wasn't an issue for me, but the doubling of
message count in the inbox was a problem for me for a while and it has gotten
much worse in 0.8. However, just today I received a blank message from 12/31/1969.

I thought that maybe the doubling of the message count was related to the fact
that I shared my profile between windows and Linux, so I copied my mail folders
to my linux partition, but it had no effect.

From what I have been able to see, the message count doubling often occurs when
I have a message in my inbox box and I receive a new message that gets added to
its thread. In other words, before receiving the new message there were no other
messages in the thread and the new message is then added to the thread. I use
the threaded view in the inbox, so it seems like there is a relationship.

Unfortunately, now it is happening pretty much everytime I delete a message. I
can usually fix it by compacting the folder, but it comes right back. When I do
run into a situation like the one describe above, then it messes things up worse
and compacting no longer fixes the problem.

At that point, I have to go delete the Inbox.msf file and then things get back
to normal for a minute anyway.

Unrelated, perhaps, I am also seeing my address book corrupted often enough that
I have started to back it up separately.

I am getting a little worried about Thunderbird's quality...I won't want to be
forced to switch to Evolution.

Comment 11

13 years ago
I believe I'm seeing this also, but symptoms (blank subject, and sender, epoch
datetime, and headres appear in msg body display) only occurs on Linux (FC3),
and appears to be improper header-lines parsing -- since doing a view source on
the msg shows one empty line between each mail header.

Has anyone found a corresponding bug filed under Moz Mail?

Comment 12

13 years ago
A friend of mine suggested that this may be being caused by the way Mail reads
the server response and detects which newline character is to be used for
parsing header-lines (even though IMAP specs at least prescribe using only
CRLF)... so if Mail has an off-by-one problem when detecting the newline char,
then that wrongly detected newline type would be used for the line-reader (hence
CRLF would be split only by \r or \n, leaving the other intact). -Just a
unconfirmed theory as to why it only happens on some clients / servers combos..

Does anyone know if TB/Mail support a debug mode where we could write the
request/response to disk (useful when we're using SSL)?

Comment 13

12 years ago
Dear Wayne Mery (who requested offline that I update this):

I Myself did not see this problem, after installing the release version of TB 1.5.. Only 1.5 beats had the problem in my case.

Comment 14

12 years ago
I have experienced this kind of problem with version 1.5.0.7 (20060909) running on Windows XP, downloading from a POP3 (Google Mail).

I haven't managed to find a reliable way to duplicate it yet, but I am getting e-mails that are blank with the beginning of epoch date/time in the recieved date field.
QA Contact: front-end

Comment 15

11 years ago
the original problem report is blank message display using imap.
reporter address is invalid, so closing WFM per comment 13 using the 


Ben in comment #14
> I have experienced this kind of problem with version 1.5.0.7 (20060909) running
> on Windows XP, downloading from a POP3 (Google Mail).

If you still see this on Thunderbird 2 and don't find a matching bug, please file a new bug.


> I haven't managed to find a reliable way to duplicate it yet, but I am getting
> e-mails that are blank with the beginning of epoch date/time in the recieved
> date field.

the date issue can be found in other existing bugs
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.