Closed Bug 216734 Opened 21 years ago Closed 21 years ago

Print preview of nested tables with inner table align=right crashes [@ nsLineBox::LastChild ]

Categories

(Core :: Print Preview, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 185357

People

(Reporter: jason.barnabe, Unassigned)

References

()

Details

(Keywords: crash, testcase, topcrash)

Crash Data

Attachments

(2 files)

The upcoming test case crashes my Moz. See bug 216652, whose test case is very
similar to this one.
Attached file testcase
Forgot to mention, WinXP Moz 2003081515.
Talkback doesn't seem to be working with my version, can someone post a Talkback ID?
Keywords: stackwanted
using a debug build circa 20030730 on Linux, I'm not crashing when print
previewing testcase, however, I get the following assertions:

###!!! ASSERTION: no font available: 'font && font->entry', file
nsFontMetricsPS.cpp, line 162
Break: at file nsFontMetricsPS.cpp, line 162
###!!! ASSERTION: Registering a placeholder for a frame that already has a
placeholder!: '!entry->placeholderFrame', file nsFrameManager.cpp, line 759
Break: at file nsFrameManager.cpp, line 759
###!!! ASSERTION: data loss - incomplete row needed more height than available,
on top of page: 'rowMetrics.height <= rowReflowState.availableHeight', file
nsTableRowGroupFrame.cpp, line 1088
Break: at file nsTableRowGroupFrame.cpp, line 1088
Keywords: crash
Confirming:
2003081904/trunk/W2K -> TB22898186W
2003071814/1.5a/W2K -> TB22898115Q
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: TB22898186W
This bug is also in M1.4.
Attached file stacktrace
Keywords: stackwanted
Summary: Print preview of nested tables with inner table align=right crashes. → Print preview of nested tables with inner table align=right crashes [@ nsLineBox::LastChild ]
Whiteboard: TB22898186W
John: Should be this crash related to your bug 185357?
*** Bug 218164 has been marked as a duplicate of this bug. ***
Just got an email from someone the other day about this crash:

Every time I bring up http://www.lindysinclair.com/ and click on "print preview"
in the pull-down print menu at the upper right of my Netscape 7.1 system,
Netscape pops up a window saying:
 
"Program Error
Netscp.exe has generated errors and will be closed by Windows.
You will need to restart the program.
An error log is being created."
 
and it writes user.dmp (43,754 KB) to the hard drive. For what it's worth, IE
6.0.2800.1106 does show a print preview without crashing.
 
System: HP Kayak XA, Pentium II 333Mhz, 192MB RAM
Windows 2000, version 5.0 (Build 2195: Service Pack 4)
 
Interestingly, Netscape 7.1 shows a print preview of a similar page,
http://www.lindysinclair.com/cooking, without any problems.

------------------------------------------------------------------------
I was able to reproduce with those steps using Mozilla 1.5a:
Incident ID 23443699
Stack Signature 	nsLineBox::LastChild b8141e02
Email Address 	jpatel@netscape.com
Product ID 	MozillaTrunk
Build ID 	2003071814
Trigger Time 	2003-09-08 17:29:36
Platform 	Win32
Operating System 	Windows NT 5.1 build 2600
Module 	gklayout.dll
URL visited 	not sure
User Comments 	not sure what happened...
Trigger Reason 	Access violation
Source File Name 	c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineBox.cpp
Trigger Line No. 	249
Stack Trace 	
nsLineBox::LastChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsLineBox.cpp, line 249]
nsBlockFrame::PushLines
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 4390]
nsBlockFrame::PushTruncatedPlaceholderLine
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3500]
nsBlockFrame::PlaceLine
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 4256]
nsBlockFrame::DoReflowInlineFrames
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3665]
nsBlockFrame::DoReflowInlineFramesAuto
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3482]
nsBlockFrame::ReflowInlineFrames
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3427]
nsBlockFrame::ReflowLine
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2536]
nsBlockFrame::ReflowDirtyLines
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2182]
nsBlockFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 860]
nsBlockReflowContext::ReflowBlock
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockReflowContext.cpp, line
535]
nsBlockFrame::ReflowBlockFrame
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 3193]
nsBlockFrame::ReflowLine
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2404]
nsBlockFrame::ReflowDirtyLines
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 2182]
nsBlockFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsBlockFrame.cpp, line 860]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 939]
nsPageContentFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPageContentFrame.cpp, line 107]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 939]
nsPageFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPageFrame.cpp, line 222]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 939]
nsSimplePageSequenceFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsSimplePageSequence.cpp, line
447]
nsBoxToBlockAdaptor::Reflow
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp, line 903]
nsBoxToBlockAdaptor::DoLayout
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp, line 645]
nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, line 1048]
nsScrollBoxFrame::DoLayout
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsScrollBoxFrame.cpp, line 356]
nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, line 1048]
nsContainerBox::LayoutChildAt
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsContainerBox.cpp, line 654]
nsGfxScrollFrameInner::LayoutBox
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 1197]
nsGfxScrollFrameInner::Layout
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 1350]
nsGfxScrollFrame::DoLayout
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 1205]
nsBox::Layout [c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBox.cpp, line 1048]
nsBoxFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 883]
nsGfxScrollFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp, line 836]
nsContainerFrame::ReflowChild
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsContainerFrame.cpp, line 939]
ViewportFrame::Reflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsViewportFrame.cpp, line 263]
PresShell::InitialReflow
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 2866]
nsPrintEngine::ReflowPrintObject
[c:/builds/seamonkey/mozilla/content/base/src/nsPrintEngine.cpp, line 2818]
nsPrintEngine::ReflowDocList
[c:/builds/seamonkey/mozilla/content/base/src/nsPrintEngine.cpp, line 2568]
nsPrintEngine::SetupToPrintContent
[c:/builds/seamonkey/mozilla/content/base/src/nsPrintEngine.cpp, line 2436]
nsPrintEngine::DocumentReadyForPrinting
[c:/builds/seamonkey/mozilla/content/base/src/nsPrintEngine.cpp, line 2215]
nsPrintEngine::FinishPrintPreview
[c:/builds/seamonkey/mozilla/content/base/src/nsPrintEngine.cpp, line 4526]
nsPrintEngine::PrintPreview
[c:/builds/seamonkey/mozilla/content/base/src/nsPrintEngine.cpp, line 1272]
DocumentViewerImpl::PrintPreview
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp, line 3147]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2019]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1270]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 845]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2856]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 861]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 936]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3533]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1220]
GlobalWindowImpl::RunTimeout
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 5038]
GlobalWindowImpl::TimerCallback
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 5394]
nsTimerImpl::Fire [c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 383]
nsAppShell::Run [c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp,
line 143]
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 479]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1307]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1673]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1695]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e814c7) 

jcarpenter0524@aol.com said she was NOT able to crash with the latest nightly. 
Has anyone seen this with a recent build?  Or has it been fixed?  Current
Talkback data shows the most recent crash being with a 9/5 build.
Keywords: topcrash
Jay: Miha Valencic was able to reproduce it with nightbuild about 9/3 on
http://www.usenix.com/events/lisa03/ (duped bug 218164). In the same time I was
unable to crash Mozilla NB on the same testcase.

Miha: Should you retry again testcase of this bug and "lisa03" page with actual
nightbuild (and please provide TalkBack incident ID, if you crash)?
Adam,

I ran the testcase. Fine, no problems. Printed OK, print preview works. Even
with regular mozilla 1.4.

As for the lisa page, it's already reported, with the talckback ID. (in the dupe
bug)

Regards,
  Miha.

*** This bug has been marked as a duplicate of 185357 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ nsLineBox::LastChild ]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: