Search result does not convert & entities in found URL

RESOLVED DUPLICATE of bug 94651

Status

SeaMonkey
Search
RESOLVED DUPLICATE of bug 94651
15 years ago
10 years ago

People

(Reporter: Met - Martin Hassman, Assigned: shliang)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.4) Gecko/20030624

When I search some something via the search sidebar and the found URL has entity
& inside (which is correct), the entity is not converted.

Reproducible: Always

Steps to Reproduce:
1. Dowload search plugin http://www.czilla.cz/sidebars/search/CzillaForum.src to
the searchplugins directory and restart Mozilla
2. In the search toolbar choose "CZilla forum" as the search engine
3. Seach for something e.g. "mozilla"
4. Click on some result in the search sidebar

Actual Results:  
The result URL in the addressbar is e.g.
http://forum.czilla.cz/viewtopic.php?t=88&amp;highlight=mozilla <- it has &amp;
inside URL.

Expected Results:  
&amp; should be converted to the & symbol

I have not tested other entities, maybe they are not converter too.

Comment 1

15 years ago
Dupe of bug 94651?

Comment 2

15 years ago
IMHO dupe. Martin, reopen if you disagree =)

*** This bug has been marked as a duplicate of 94651 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Search result does not covert &amp; entities in foud URL → Search result does not convert &amp; entities in found URL
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.