Closed Bug 216801 Opened 16 years ago Closed 16 years ago

firebird load startup time needs to be improved

Categories

(Firefox :: General, enhancement)

x86
Windows 2000
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 7251

People

(Reporter: bfults, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030819 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030819 Mozilla Firebird/0.6.1+

On my system (Win2K SP4, Dual Palominos @ 1666, 768MB DDR) it takes
approximately 6.5 seconds to completely load Firebird from the time the exe is
invoked to the time the window is loaded and cursor is blinking in the address
bar. IE6 SP1 takes about 1.5 seconds. I think a large priority of Firebird
should be to compete with IE on the Windows platform, mainly meaning speed. I'm
sure an intensive efficiency audit could only better the performance of the
Firebird browser. I wouldn't even be opposed to a pre-loader type application
that would start with Windows (in that case, starting as an NT service would be
a MUST) like Seamonkey has.

Reproducible: Always

Steps to Reproduce:
1. Reboot
2. Start Firebird
3. Observe startup time

*** This bug has been marked as a duplicate of 7251 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.