crash while the site's main page is loading

VERIFIED WORKSFORME

Status

()

Firefox
General
--
critical
VERIFIED WORKSFORME
14 years ago
12 years ago

People

(Reporter: modjeska, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

While the browser is loading the main page at http://www.pollen.com, the browser
exits without any message. Apparently the page is not valid (as shown by
validator.w3.org), but Mozilla should not crash in any case. The same problem
occurs with Firebird 0.6.1. Opera also crashes while attempting to load this
page, although Internet Explorer does not crash.

Reproducible: Always

Steps to Reproduce:
1. Enter the URL www.pollen.com into the browser's address bar.
2.
3.

Actual Results:  
The browser exited without warning or message.

Expected Results:  
Displayed as much of the page as could be displayed correctly, while ignoring
the part containing an error.

Comment 1

14 years ago
*** Bug 216809 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
WFM. Can you try it on the latest nightly? (A quick link is available on the
mozilla.org front page.) Might help, might not.

My *guess* is that it might be Java-related; an applet is in the upper right
corner. What version of the Java runtime do you have installed? You may want to
try uninstalling and reinstalling it, or, if you don't have it already, get the
latest version. Once again, it might help, or it might not ... but it's worth a try.
(Reporter)

Comment 3

14 years ago
Good suggestions. I downloaded the latest nightly build of Firebird, dated
August 20. I also uninstalled my old Java runtime (1.3.9) and installed a new
one (1.4.2). Unfortunately, the problem persists.

I also have impression that the problem is caused by the Java applet in the
upper right corner. During one slow page loading with Firebird 0.6.1 and the JRE
1.3.9, the applet was the last visible item waiting to be painted (with a Java
logo over a blank gray rectangle marking the applet area), before Firebird crashed. 

Updated

14 years ago
QA Contact: asa

Comment 4

14 years ago
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031002 Firebird/0.7+

(but I don't have Java installed)

Comment 5

14 years ago
I can't reproduce it on Firebird 0.7 (Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.5) Gecko/20031007 Firebird/0.7) with java and javascript enabled and
j2re1.4.2_01 installed.
I am running RedHat 8.0 and kernel 2.4.20-20 on a PC
(Reporter)

Comment 6

14 years ago
I *can* reproduce it in Firebird 0.7 (Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.5) Gecko/20031007 Firebird/0.7) with Java and JavaScript enabled, and
J2RE 1.4.2_02 installed.

I am running Windows 2000 (5.00.2195, Service Pack 4) on an IBM ThinkPad (T22).

Comment 7

14 years ago
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216
Firebird/0.7+

There seems to be a Java app loading. Maybe it is a problem with your version of
java? 

Reporter: Can you try this with a newer version and confirm that this is still a
problem?

Comment 8

14 years ago
I'm not seeing this on a latest nightly with Win2K, neither is Asa on WinXP.
-> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
QA Contact: bugzilla
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216
Firebird/0.7+

This problem still occurs in the nightly build from December 16, 2003. 

I have installed the JRE 1.4.2_02, which is the newest available from java.sun.com.

Approximately 3 weeks ago, I reformatted the computer's C drive, installed
Windows XP (with updates), and reinstalled all required applications. 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 10

14 years ago
Created attachment 137594 [details]
Registry fix to make Java 1.4.2 work with lastest firebird

Registry fix to make Java 1.4.2 work with firebird.

Comment 11

14 years ago
This bug does not work for me.
Using latest Build 
 - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216
Firebird/0.7+

with JRE 1.4.2_01 and the posted regitry fix to make it work.
This registry entry should be made to the register with the installer.
If you use the .zip that may be the problem.
(Reporter)

Comment 12

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

I installed the registry fix posted above. The bug still occurs. 

Before making the registry fix, I had not (yet) experienced any problems with
JRE 1.4.2_02 and Firebird 0.7.

What is causing this discrepancy between bug testing results from various people?

FYI, when using Opera 7.22 and IE 6.0.2800 (with Sun's Java),
http://www.pollen.com also crashes these browsers. Assuming that this is a JRE
problem, is there a way to partly insulate Firebird or to exit more gracefully?

Comment 13

14 years ago
Check to see if it is just this frame
http://www.pollen.com/topnav.asp
(Reporter)

Comment 14

14 years ago
Yes, naturally.

Comment 15

14 years ago
I was testing this bug with the lastest build for bugday (12-16) 
Now I'm back with my own (12-07) build. No crash either.
I unistaled Java and downloaded the lastest version at www.java.com it is
(Version 1.4.2_03 (build 1.4.2_03-b02) )
If yall could unistall it , apply the registry fix and reinstall the latest java
to try.
(Reporter)

Comment 16

14 years ago
I first reported the problem with www.pollen.com on June 24, 2003, with Sun's
JRE 1.3.9. Unfortunately, I don't have time to track each micro-release of
Firebird and Sun's JRE. Is there a reason to expect a fix in the latest releases?

Comment 17

14 years ago
I think this should be WFM, using a recent nightly ( Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.7a) Gecko/20040115 Firebird/0.8.0+ (MozJF)) on
Windows 2000 the site loads without any problem.

My Java version is 1.4.1_02
Still not seeing this with a 2004-01-31 build on Windows 2000.
Nobody is seeing this, except the reporter. Must be a local issue.
-> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.