Installed skins and modules. Can no longer launch Firebird.

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: mozilla, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 0.6.1

Installed a half dozen skins and modules and now I get the following error:

XML parsign Error: undefined entity
Location: chrome://browser/content/browser.xul
Line Number 157, Column 38:

<key id="focusURLBar2" key="&openCmd2.commandkey;" 
command="Browser:OpenLocation"

Reproducible: Always

Steps to Reproduce:
1.  Installed half a dozen skins and modules
2.Launch Firebird
3.

Actual Results:  
Can not launch and no apparent way to recover. :(

Expected Results:  
"Die" more gracefully.  Allow user to remove offending skin or module *after* 
launching.
unfortunately, because of how the UI is implemented, if an extension breaks the
UI, its broken, period.

Bad extensions can hose firebird, just like bad patches can hose any application.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
"unfortunately, because of how the UI is implemented, if an extension breaks 
the UI, its broken, period." 

Let me get this srraight.  It is broken, and tere's no way to "back out" the 
changes, and the only thing I can do is start over (and redo all my settings.)
And you seriously expect people to use Firebird? Sounds like a nightmare for 
developers and worse for end users. I guess it is back to IE for me.  I never 
thought I'd say that Microsoft has a better attitude toward customers than an 
open source project.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Bad patches from Microsoft can hose plenty of applications.  Remove and
reinstall of components is something that does unfortunately have to happen with
Microsoft products too.  Extensions have the power to do everything that they do
because they insert themeselves into the UI and other parts of the code.  There
are plans to make extensions more plugin-like, and thus less potentially
destructive, but in the meantime things like this will happen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

15 years ago
What patches from Microsoft do you think have ANYTHING to do with this?  The 
problem started with I installed Firebird skins and modules only. Please don't 
introduce red herrings.

I don't mind having to reinstall skins--particularly if they are bad. But I 
can't even launch Firebird.  Uninstalling the entire application means that I 
suddenly loose all my preferences (in addition to the inconvenience.

There should always be some way to uninstall any skin that might have an error 
without unintalling all of Firebird. How about the simple solution--revert to 
the default skin for g-d's sake? 

I think that giving Extensions no way to fail gracefully is a poor 
architecture decision. Furthermore, I have a) no idea which extension is at 
fault b) no idea how to uninstall it (without being able to start firebird!

All of this must be solved before Firebird will be close for "prime-time" use.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Badly written extensions will cause errors like this.  Given the error, it was
probably a missing .dtd file in one of the extensions, which will cause a
parsing error like this.  The author of the extension that caused the error is
to blame, not Firebird, hence the bug is INVALID.

If you install extensions to the program directory, you can delete and reinstall
the application without affecting your profile, including your settings. 
However, if you install to the profile directory, it will probably break your
profile, and you can create a new profile and import your bookmarks and copy
over passwords etc.

As for Microsoft, you mentioned going back to IE.  A bad patch from any program
vendor or third party WILL break the application, especially if it overwrites
critical files.  Most patches from software companies go through enough QA to
ensure that this won't happen, however an extension from a single author
probably doesn't get anywhere near the amount of testing.  Thus it may or may
not work properly or be compatible with other extensions.  Once there are
"official" extensions this will be safer for users as they will have enough
testing to prevent problems like this.

There is no way to "fix" the problem of bad extensions from preventing the
software from loading, short of removing the ability of extensions to modify the
core of the program.  That is a key element for Firebird (complete
extensibility), therefore the answer is more testing and QA for extensions.

Please do not reopen this again.  If you wish to carry on a discussion about
best practices and the limitations of XPI installations, feel free to email me
any time.
URL: N/A
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
QA Contact: asa → mpconnor
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.