Search terms with plus plus (++) get truncated

RESOLVED DUPLICATE of bug 178149

Status

SeaMonkey
Search
RESOLVED DUPLICATE of bug 178149
14 years ago
9 years ago

People

(Reporter: Jonah Bishop, Assigned: shliang)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Using Google as the engine, searching for a term such as C++, J++ or K++ fails
because the ++ gets stripped out of the term. Mozilla seems to replace the plus
characters with spaces. As a result, the search returns unwanted results.

Reproducible: Always

Steps to Reproduce:
1. Open the sidebar search panel.
2. Search for a term including two plus signs (such as C++).
3. Note that the plus signs have become spaces.

Actual Results:  
The search simply returns results for an unwanted keyword (C versus C++).

Expected Results:  
The plus signs should not be removed, but should be sent to Google as part of
the search keywords.

*** This bug has been marked as a duplicate of 178149 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.