If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Popup (non-evil one) displays as source instead of HTML

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Juan Carlos Castro y Castro, Assigned: Darin Fisher)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

There's a link in that page which, when clicked, displays the contents in source
HTML instead of rendering it.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.vivo-rjes.com.br/ (page in Portuguese)
2. Pass mouse over "Vivo Pós" in the grey horizontal menu
3. Select "Vivo Online"
4. Click on the "aqui" link at the end of the text paragraph.


Actual Results:  
Popup comes up as HTML source -- with headers and all!!! In IE6 it displays
correctly.

Expected Results:  
Render HTML inside the popup.

Accessing the Internet through MS ISA Server.

Comment 1

14 years ago
This is typically a server mime type problem, not a Mozilla problem, but it
works for me in 1.4 20030813 for OS/2.

Comment 2

14 years ago
WFM, 2003-08-19-05 trunk Linux

Comment 3

14 years ago
The server is not properly configured: It just doesn't send a content type for
the pop-up site. IE probably just guesses that it's HTML by seeing the tags
(which is bad).

OS=All, over to HTTP networking and confirming, but proposing Invalid.

BTW, it does _not_ WFM using a current Linux CVS build.

The headers:

http://www.vivo-rjes.com.br/hotsite_TOnline/index.cfm



GET /hotsite_TOnline/index.cfm HTTP/1.1

Host: www.vivo-rjes.com.br

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030729

Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1

Accept-Language: de,en;q=0.5

Accept-Encoding: gzip,deflate

Accept-Charset: ISO-8859-15,utf-8;q=0.7,*;q=0.7

Keep-Alive: 300

Connection: keep-alive

Referer: http://www.vivo-rjes.com.br/area_cliente_top/telefonicaonline.asp



HTTP/1.x 200 OK

Date: Thu, 21 Aug 2003 20:58:27 GMT

Connection: close

Set-Cookie:
WEBTRENDS_ID=80.142.9.86-4156538192.29583398::942B0594370E39B9FD04323D29277177;
path=/; expires=Fri, 20-Aug-2004 20:58:27 GMT

Assignee: general → darin
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: HTTP
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: general → httpqa
Mozilla must use the unkown content decoder and decide itself if the server
sends no mime-type.

>IE probably just guesses that it's HTML by seeing the tags
(which is bad)

No, that's the correct way if there is no content-type a content type is not a
"must", it's a "should" 

This is wfm with a 1 day old nightly build on win2k
(Assignee)

Comment 5

14 years ago
WFM firebird linux 20030819 trunk.

oliver: looks like you have livehttpheaders installed... can you try with that
removed?  can you try with a new profile for that matter?  thx!  a HTTP log
might be helpful too if you are still seeing headers / HTML source.

Comment 6

14 years ago
With a fresh profile, this WFM as well (LiveHTTPHeaders is still installed). I
wonder what's happened to my main profile to cause this behaviour.

Comment 7

14 years ago
This bug worksforme with Windows Seamonkey builds 2004020909
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.