Different Tabs should handle cookies from same site differently

VERIFIED DUPLICATE of bug 117222

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 117222
15 years ago
3 years ago

People

(Reporter: amlan_c, Assigned: darin.moz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Different Tabs should handle cookies from same site (same url) differently. A
classic example of this is to be able to logon to the same site (that sets a
user specific cookie) as two different users simultaneously, from 2 tabs on the
same browser.

Reproducible: Always

Steps to Reproduce:
1. Logon to a site that sets a cookie as one user
2. Open a new tab and try to logon to the same site (same url) as a different user
3. You will not be able to do it, as the cookie set by the first one will be
sent for second tab as well

Actual Results:  
A classic example of this is to be able to logon to the same site (that sets a
user specific cookie) as two different users simultaneously, from 2 tabs on the
same browser.

Expected Results:  
Should be able to set same cookies (same name) with different values from the
same site (same URL same path) on separate tabs
don't think this is feasible/desired.... at all

this is the entire point of cookies, to let you switch windows/tabs etc without
having to log on...
Component: General → Complex Text Layout
OS: Linux → All
Product: Firebird → Browser
Version: unspecified → Trunk
(Reporter)

Comment 2

15 years ago
This is feasible if we have 
a) a cookie manager instance per tab 
b) tabs are persistent
c) stored cookies are in reference to the tab it was set to

As far as desire is concerned, this can be made configurable
so the user can turn it on if reqd.
argh, -> Cookies

its *technically* feasible, but it would increase footprint and code size, along
with introducing unfamiliar cookie behaviour to users

recommending WONTFIX
Assignee: blake → darin
Component: Complex Text Layout → Cookies
QA Contact: asa → cookieqa

*** This bug has been marked as a duplicate of 117222 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
*** Bug 219566 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.