user specific directories are created under C:\Documents and Settings\<user>\Application Data. I want to control where these folders go.

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: kkratochvil, Assigned: bryner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Opera/7.11 (Windows NT 5.1; U)  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

One annoyance I have with the browser: Firebird creates the following 
directories under C:\Documents and Settings\<user>\Application Data
Mozilla
Phoeniz
Talkback

I am trying to run "clean" (not install anything directly on my machine).  I 
tried putting the folders in the same path as the executable (usb device) but 
the folders were still created on my C drive.  
Is it possible to disable the creation of these folders?

Reproducible: Always

Steps to Reproduce:
1. Run Firebird from my flash drive, directories are created
2. delete directories / move them to the flash drive
3. run firebird, directories are again created on my C drive.  I don't want this 
behavior!

Actual Results:  
Directories are created in an un-wanted area.  

Expected Results:  
I would like to be able to control where the directories are created.  I don't 
want things stored in the registry either because I want to be able to run 
"clean" -- no reg entries, no misc directories created on my hard drive.

Comment 1

15 years ago
Start mozillafirebird.exe with the -p switch. Create a new profile at a location
of your desire and delete the default profile afterwards.

Not a bug. -> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
Simon, I tried your suggestion. I created a new profile and the folders
Mozilla, Phoenix, Talkback were still created in the default location
under C:\Documents and Settings\<computer login>\Application Data.

I created a new profile, ran mozilla under that new profile, exited
mozilla, and deleted the three folders. When I re-ran mozilla it
prompted me to create a new profile. It appears that the folders
that are created under "application data" are necessary for
Firebird's operation. I want to control where these folders are
placed and I do not see a way to do that. Please provide additional
information as to how I can work around this problem! 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

15 years ago
Also, a randomized folder (like fw7d2w6t.slt) was created under these folders:
C:\Documents and Settins\{User Login}\Application Data\Mozilla\Profiles\{Profile
Name}\fw7d2w6t.slt.

Thank you

Updated

15 years ago
QA Contact: asa

Comment 4

15 years ago
taking over qa abandoned bugs.
QA Contact: bugzilla

Comment 5

15 years ago
kkratochvil@mvps.org, you have to specify where to put the folder in the create
profile dialog. This works for me like a charm here. Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
QA Contact: bugzilla → build.config
You need to log in before you can comment on or make changes to this bug.