the description for caret browsing in the options dialog ("Move system caret with focus/selection changes") is unclear

VERIFIED WONTFIX

Status

()

Firefox
Preferences
--
minor
VERIFIED WONTFIX
14 years ago
11 years ago

People

(Reporter: Will Levine, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030822 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030822 Mozilla Firebird/0.6.1+

"Move system caret with focus/selection changes" is really confusing.  I
couldn't figure out what it was when I saw it at first.  Then I realized it just
turned on/off caret browsing like F7.  This really needs to be clearer.  Maybe
we should put some text like the stuff that is in the warning box that happens
when you push F7.  Maybe "Place a moveable caret in web pages to allow selection
of text without a mouse".  Just because the option in IE is really confusing, I
don't think we should emulate that.

Reproducible: Always

Steps to Reproduce:
1. Tools>Options>Advanced
2. Read the Description of Caret Browsing
3.

Actual Results:  
Confusing description

Expected Results:  
Description that makes sense

Comment 1

14 years ago
I have to say, I agree entirely - confirming.

And I was mightly amused too, when I realised that the *is* no system caret
involved in the F7 mode! (I'm looking for a bug for this)
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is the exact terminology that IE uses, this is intended to make it easier
for transitioning users.  I think most Mozilla users will use F7 anyway, so this
isn't an issue in any case.

-> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 3

14 years ago
I can't see how it can "make it easier for transitioning users" - it doesn't do
the same thing at all! (it most certainly doesn't show a caret in the middle of
a web page in IE, like Gecko does - I couldn't actually find IE doing *anything*
different with the option on or off)

Comment 4

14 years ago
Verified WONTFIX 2003-09-03
Status: RESOLVED → VERIFIED

Comment 5

12 years ago
Continued in bug 217030.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.