BIG5NOASCII (for X11 font encoding) should not include Big5 UDA's

RESOLVED WONTFIX

Status

()

Core
Internationalization
RESOLVED WONTFIX
15 years ago
9 years ago

People

(Reporter: Jungshik Shin, Assigned: Jungshik Shin)

Tracking

({intl, regression})

Trunk
intl, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
In bug 9686 and bug 181725, BIG5 UDA #1, #2 and #3 are added to Mozilla's Big5
converter (bug 181725 comment #10). This is fine as long as Big5 as _character_
encoding is concerned. However, most X11 fonts (XFree86, Solaris, HP/UX) with
'big5-0'(XFree86), 'big5-1'(Solaris) [1], and 'hpbig5-' [2] _font_ encodings
don't have any glyph for UDA #1, #2 and #3.  Because Mozilla's Big5NoASCII (to
be used for X11 font with big5-0, big5-1, hpbig5-) encoder uses big5.uf mapping
table with UDA's, X11 big5-0,1, hpbig5- fonts are incorrectly cosidered as
covering Big5 UDA's although they don't.

This can be easily fixed by splitting big5.uf (from Unicode to Big5) into two
mapping files, big5.ut and big5uda.ut. This is likely to speed up Mozilla's
rendering of Big5 document (Gfx/X11, Gfx/Gtk ports with X11 core fonts) because
the mapping for less frequently used UDA's wouldn't have to be looked up most of
time.


[1][2] I'm making a guess here. Mi-Young and Masaki, can you confirm?
(Assignee)

Comment 1

15 years ago
Created attachment 130261 [details] [diff] [review]
a patch

In my comment #0, I meant 'uf' (from unicode) rather than 'ut' (to unicode)
mapping file. 

This patch has a new file, big5uda.uf and diff to big5.uf (UDA's excluded) and
nsUnicodeToBig5.cpp. No change is necessary for nsUnicodeToBIG5NoASCII.cpp
(Assignee)

Comment 2

15 years ago
Comment on attachment 130261 [details] [diff] [review]
a patch

asking for r/sr,

this is a rather trivial fix although diff is large.
Attachment #130261 - Flags: superreview?(blizzard)
Attachment #130261 - Flags: review?(smontagu)
(Assignee)

Comment 3

15 years ago
big5.uf was generated from Anthony's Big5 mapping file (uploaded to bug 9686)
with UDA #1, UDA #2 and UDA #3 *excluded*. So, its coverage is restricted to
Big5 'proper' without any UDA blocks. This coverage is in agreement with X11
core fonts for Big5. We have to use this mapping for Big5NOASCII because that
converter is for X11core fonts.
No change is necessary in nsUnicodeToBig5NOASCII.cpp because the content of
big5.uf is changed NOT to include Big5 UDA blocks. 


big5uda.uf (new file) was generated from the same Big5 mapping file. However,
this time, all Big5 Proper code points (*NON-UDA*) are _excluded_. Instead, only
UDA blocks are included. 

Big5 encoder(nsUnicodeToBig5) will use US-ASCII, big5.uf (for Big5 proper) and
this file (big5uda.uf).   
Summary: BIG5NOASCII (for X11 font encoding) should not include Big5 UDA's → BIG5NOASCII (for X11 font encoding) should not include Big5 UDA's
Comment on attachment 130261 [details] [diff] [review]
a patch

r=smontagu
Attachment #130261 - Flags: review?(smontagu) → review+
(Assignee)

Comment 5

15 years ago
Thanks for r. However, we may have to hold it for a while. I just learned that
X11core fonts for HP/UX (hpbig5-) have UDA's (I don't know whether they have all
three UDA's, or just UDA #1). XFree86 core fonts don't have any of them. I 'm
still waiting for Masaki's answer on Solaris. If both Solaris and HP/UX have
UDA's, we may just have to leave big5.uf file alone because X11core fonts on
Linux, FreeBSD and other platforms (XF86 is targeted at) are out of fashion and
most people use Mozilla-Xft.
Attachment #130261 - Flags: superreview?(blizzard)
QA Contact: amyy → i18n
WONTFIX X11 core font bug
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.