Choosing Save Page, Image, or Link as... does nothing (Mac only)

VERIFIED FIXED in Firebird0.7.1

Status

()

Firefox
Menus
P1
major
VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: Jerry Talkington, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({regression})

unspecified
Firebird0.7.1
PowerPC
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030823 Mozilla Firebird/0.6.1+ (jtalkington nightly)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030823 Mozilla Firebird/0.6.1+ (jtalkington nightly)

Choosing Save Page/Image as... from either the regular menu or the context menu
does nothing.  No dialog, no crash, nothing.  This started a couple of days ago
with the nightlies I'm making.

Reproducible: Always

Steps to Reproduce:
1. Open a web page.
2. Chose "Save Page As..."
3. Watch the magic.

Actual Results:  
Nothing.

Expected Results:  
Saved the page.
(Reporter)

Comment 1

14 years ago
"Save Link To Disk..." does work, however there is no dialog box after clicking
that (the elipses indicate that there should be one.

Comment 2

14 years ago
Confirmed with 2003-08-23 CVS build on OS 10.2.6.
Marking New.
It seems like this is Mac only.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Keywords: regression

Updated

14 years ago
Summary: Choosing Save Page/Image as... does nothing → Choosing Save Page/Image as... does nothing (Mac only)

Comment 3

14 years ago
If I set "Save all files to this folder" in Preferences->Downloads,
only "Save link to Disk" becomes to work.

Comment 4

14 years ago
Confirming this bug with Gecko/20030926 Firebird/0.7 (MacOs X 10.2.6)
Contextual menu does not work either (Save image, Save link as).

Comment 5

14 years ago
Also confirming this bug - reproducible: always.
After selecting "Save Page/Image As..." in either the regular menu or
command-click contexual menu, nothing happens.  Am still able to save images by
dragging them to my desired location in the Finder though.

Firebird details:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031003
Firebird/0.7 (MacOS 10.1.5)

Comment 6

14 years ago
jerry, is bug 221841 a dupe of this?  save link to disk... doesnt work for me
(0.7 candidate 20030926).

Comment 7

14 years ago
*** Bug 221841 has been marked as a duplicate of this bug. ***
*** Bug 222273 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
I confirm this bug with Firebird 0.7 [Mozilla/5.0 (Macintosh; U; PPC Mac OS X
Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7] and Mac OS X 10.2.8

Comment 10

14 years ago
I am also having this problem under 0.7.  Worked under 0.6.1.

Comment 11

14 years ago
We can see the following error in JavaScript Console, if we set
user_pref("javascript.options.strict", true);
user_pref("javascript.options.showInConsole", true);

Error: [Exception... "Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [nsIProperties.get]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://browser/content/contentAreaUtils.js :: foundHeaderInfo :: line 264" 
data: no]
Source File: chrome://browser/content/contentAreaUtils.js
Line: 264
-> me
Assignee: blake → bugs
Created attachment 133900 [details] [diff] [review]
browser/ part (use the correct directory service constant for MacOS X)
Created attachment 133901 [details] [diff] [review]
Patch for nsprpub/ 

XP_MACOSX should be in the list of OSes that require tm.tm_zone to be set to
null... otherwise strftime gets very cranky with us (= crash).
-> high priority 0.7.1 
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → Firebird0.7.1
Attachment #133901 - Flags: review?(wchang0222)

Comment 16

14 years ago
Comment on attachment 133901 [details] [diff] [review]
Patch for nsprpub/ 

r=wtc.	I will change XP_MACOSX to DARWIN when I check in
this patch.
Attachment #133901 - Flags: review?(wchang0222) → review+

Comment 17

14 years ago
Comment on attachment 133901 [details] [diff] [review]
Patch for nsprpub/ 

Ben, could you tell me what's the format string that
you pass to PR_FormatTime to cause it to crash in strftime?
I'd like to add this test case to the NSPR test suite.
Right now NSPR's test suite is testing:
    "%c GMT"
    "%T"
    "%d %b %Y %H:%M:%S"
Wan-Teh, 

I've sent you mail detailing exactly how this was being called. In summary, 

PR_FormatTime is being called with just "%Z" by PR_FormatTimeUSEnglish, which is
being called with "%a %b %d %H:%M:%S %Z %Y". Looks like nspr is missing a test
for %Z, and %Y

Comment 19

14 years ago
Comment on attachment 133901 [details] [diff] [review]
Patch for nsprpub/ 

a=asa (on behalf of drivers) for checkin to the 1.5 branch.

Comment 20

14 years ago
*** Bug 222341 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Summary: Choosing Save Page/Image as... does nothing (Mac only) → Choosing Save Page, Image, or Link as... does nothing (Mac only)

Comment 21

14 years ago
WFM 20031024 Firebird/0.7+ I guess the fix was checked into the trunk as well as
the branch. :)
Fixed, 1.6a trunk and 1.5br
Fixed, 1.6a trunk and 1.5br
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

11 years ago
QA Contact: bugzilla → menus
Old, now-fixed bug that works just fine on:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/2007072004 Minefield/3.0a7pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.