Double clicking/Alternate clicking on close tab button/tab bar opens new tab

VERIFIED DUPLICATE of bug 216470

Status

()

VERIFIED DUPLICATE of bug 216470
15 years ago
12 years ago

People

(Reporter: Hikaru, Assigned: hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030817 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030817 Mozilla Firebird/0.6.1+

Only double clicking on tab bar should open a new tab. But there are other weird
behaviours that happen when you double click on the close tab button or
alternate (left then right) click on the close tab button or the tab bar.
a) Double click on close tab button - Closes two tabs then opens one new one
b) Alternate click on close tab button - Closes one tab and opens one new one
c) Alternate click on tab bar (empty space) - Opens new tab
Alternate click doesn't count as double click, therefore, it shouldn't open a
new tab when used in the tab bar. The behaviour on the close tab button should
also be fixed so that opening a new tab doesn't function there.

Reproducible: Always

Steps to Reproduce:
a) 1. Click twice on the close tab button in the tab bar
b) 1. Left click on the close tab button in the tab bar followed by a right
click on the same place
c) 1. Left click on an empty space in the tab bar (Not occupied by tab) followed
by a right click on the same place

Actual Results:  
a) If there are two or more tabs open, two tabs is closed and a new tab is opened
b) If there are one or more tabs open, one tab is closed and a new tab is opened
c) A new tab opens

Expected Results:  
a) Two tabs should be closed and no new tab should open
b) One tab should be closed and no new tab should open
c) Nothing should happen

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 216470 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.