RFE: Send email message in background

RESOLVED DUPLICATE of bug 82998

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 82998
15 years ago
13 years ago

People

(Reporter: Adam Masri, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Currently, when we're composing a new email message and go to send it, a
non-modal dialog (non-modal on OS X anyway) displays in front of all other
windows telling us that the email is being sent. This dialog remains on the
screen until the send is complete, at which time the compose window closes and
we can continue using Mozilla.

Instead, I'd like to hit send, and immediately have the compose window
disappear. A message and perhaps a chasing arrows or scrollbar indicator at the
bottom of the Mail & Newsgroups window would tell us that the send was occuring
in the background. This totally non-modal background send process would allow us
to continue to use Mozilla -- composing new messages, reading more email,
surfing other webpages. We would not have to wait until the send was complete
before we could continue working.

I can approximate this behaviour currently by going offline -- I can compose my
emails, hit Send Later to store them, then go online and send them all at once.
However, this is less than ideal. Every time an email refers to a foreign
website, I would need to go online, view that page, then go back offline to send
more email.

- Adam

Comment 1

14 years ago
Reporter, why do need to go offline? Can't you "Send Later" (in File menu, or
Ctrl+Shift+Enter) when online?

Anyway, I think bug 82998 wants the same thing.

*** This bug has been marked as a duplicate of 82998 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.