indews.com - download will not start

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English Other
RESOLVED WORKSFORME
14 years ago
3 years ago

People

(Reporter: Reinhard Berger, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

This page contaions some maps for a game.
instead of downloading the file in binary mode, it will be displayed within the
browser.

The option Save Link traget as will save the link a HTML file thereforce the
compressed RAR will not open.



Reproducible: Always

Steps to Reproduce:
1.connect to the given URL
2.click on download


Actual Results:  
The binary file will be displayed as HTML text file within the browser.
This is wrong.

Expected Results:  
The File Save Dialog should appaer asking me where to store it.


Works with MS IE 6.0

Comment 1

14 years ago
it tells me "You don't have permissions to open the file."

My guess is that it's a poorly configured server: all documents are announced as
being HTML even if they're another type. Mozilla follows the instructions by the
server and will try to render it as HTML.

You'll have to figure this out from the header information [perhaps you can use
LIVE HEADERS to do this http://livehttpheaders.mozdev.org/].

PS:
If the server is indeed poorly configured, 
1) you can contact the webmaster to tell him this
2) if IE works that is only because IE does something terribly wrong : It
overrides what the server says and thinks it knows better than the people that
put up the page.
3)workaround might be to right-click and SAVE TARGET AS 

please report back your findings here
Patrick is right. The HTTP server serves the files as text/plain, which is
completely wrong.

Right-clicking->"Save link target as" should work, yes.

Recommend INVALID, since it is not a Mozilla bug.

Comment 3

14 years ago
instead of INVALID this belongs under Tech Evang  -> Mozilla's eforts to
encourage webmasters to adhere to specifications. 

Moving. Unsure about new component as site is unclear about origin, assuming
English-other.
Status: UNCONFIRMED → NEW
Component: Browser-General → English Other
Ever confirmed: true
Product: Browser → Tech Evangelism
Version: Trunk → unspecified
(Reporter)

Comment 4

14 years ago
SAVE LINK as does not work !!

instead it will try to save the file as "redirect.php".

Sure it could be that the server is badly configurated but unfortunaly mozilla
is the only Web browser that has this problem.

IE and Opera does not have any problems with this page, so it seems that there
must be a solution to deal with it.

Alot of so called "badly" sites are around the net not holding themself correlty
to all standarts.

The task of a Browser Software should be to be as much compatible to all sites
even if they does not use 100% the correct standart.

What i dont understand is, that Mozilla opens this link in the Browser, since
when you look to the url that opens in the 2nd window you will find the
extension .RAR in it, so Mozilla should know that this is a filerequest.

How does Opera and IE deal with this ?

It is a shame that Mozilla fail with it when others do not.

This is then why people mostly always say : IE is the Best Browser , no wonder
if it deals correctly even with missconfigurated pages.

I would say it is recomanded that Mozilla too can deal with this , even the
workaround "Save as" where it MUST/SHOULD work does not work.

This is definatly a bug in Mozilla and not invalid one.

It would not be a Bug when it does not work with other browsers.

I discovered already some stupid sites (with java scripts) that only works with IE.

As long as Mozilla Developer does say hey this is IE **** and has nothing to do
with Mozilla, they should not wodner why IE is so much liked by the people and
this is setting standarts since people try mostly out thier sites with this
explorer and (unfortunaly) not with Mozilla & CO (sure serious one would).

You can not deny that Mirco **** Software has one again etablished standarts.

Mozilla should however be better or least comptaible as well to this **** MS
IE ONLY configurated sites.









Patrick: yes ofcourse :) Thank you.

Reinhard: Mozilla opens the file in the content-area because it is served as
text/plain from the HTTP server, which means that it is a plain-text file. It
doesn't matter what extension it is.

Mozilla does the right thing.

There is a "workaround", however. Go to Edit->Preferences->Navigator->Helper
Applications. Then click the "New Type" button, and write this in the box:
MIME Type: text/plain
Description: RAR Files served as text/plain
Extension: rar

And check that it should "Save to disk".
I'm not sure this works, but it's worth a try.
(Reporter)

Comment 6

14 years ago
as patrick wrote before i installed that live headers (still have no clue for 
what it is ) and checked again the site.

Suprise Suprise it works !

Now Mozilla displays the FileSave Dialog and even saves the rar file correctly.

Very intressting this thing.

I'll try the other solution now too and report again if ti works ot not.

Thanks for the hint to that live thing.

(Shoulnd this thing then not be always installed??)

Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 7

14 years ago
Reinhard: suppose you have a web server and you want to display something [a
file] as text on your web page. Let's assume it's a HTML file where you want to
show your visitors the code for. You set up your server as to show that page as
TEXT/PLAIN.

Now IE comes along, is told by the server that it should be shown as PLAIN TEXT,
but IE thinks it recognizes HTML. So instead of displaying the source it will
RENDER it thus bypassing the explicit instructions from the person that put the
page there [and possibly even owning the content].

So IE second guesses what the OWNER of the site had in mind for that page.

Of course IE gets lucky in the case of poorly configured servers but the
hierarchy as laid out for the web is such that the one who OFFERS the content
should prevail and not the client.

This issue isn't so much about bad HTML, it's about who has priority on how
something is transferred and for the reasons laid out above, the SERVER should
not be second guess by the CLIENT. Mozilla adheres to this standard, IE doesn't.

Fortunately, Mozilla offers several workarounds. 

The Live Headers thingy is not useful for most people, but it IS very helpful
when debugging certain problems. Therefore it's not part of the standard Mozilla
download but developers needing to tool can simply add it. What it does is it
gives additional information about the information that is sent by the client
[requests for pages] and the server [formats and how to handle]. This allows you
to trace down the origin of such problems. But as i said, for the average user
this is hardly interesting.

PS: I'm reopening the bug as a Tech Evang bug, because the site is still wrongly
configured. 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: Download will not start → indews.com - download will not start
(Reporter)

Comment 8

14 years ago
It seems that more and more "bad" configuraed sites goes around.
At least evrytime when i try to download such "map" files i found just evry 2nd
page refuses to work with mozilla download.

just like this 
http://www.blitzkrieg-forever.de/include.php?path=content/download.php&contentid=35&PHPKITSID=0be2838eff500cd5ab8713f77fc1754b

This page AGAIN says plain/text and will loaded into mozilla/firebird instead of
opening a download window.

And again the workaround "save as" will only save the link page to disk and not
the contends of the download.

There must be something done in future to overcome this problem since as i
already told alot of this map sites uses the same tecinc now and all this
refuses to work with Mozilla now.

This cant be the way that mozilla always refuses to work with such pages.

WFM
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WORKSFORME

Comment 10

13 years ago
(In reply to comment #8)
> It seems that more and more "bad" configuraed sites goes around.
> At least evrytime when i try to download such "map" files i found just evry 2nd
> page refuses to work with mozilla download.
> There must be something done in future to overcome this problem since as i
> already told alot of this map sites uses the same tecinc now and all this
> refuses to work with Mozilla now.
> 
> This cant be the way that mozilla always refuses to work with such pages.

In fact, this will be solved pretty soon, but not by Mozilla. With the changes
in Service Pack 2 for Windows XP, Microsoft will also FINALLY adhere to the
standards that Mozilla already adheres to. Which means that from then on, these
sites will also appear broken when using IE and therefore, the number of broken
site will drastically reduce.

Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.