tabbing between elements on form loses focus

RESOLVED DUPLICATE of bug 147927

Status

()

Core
HTML: Form Submission
RESOLVED DUPLICATE of bug 147927
15 years ago
15 years ago

People

(Reporter: hoecoop, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030824
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030824

When filling out a form to add recipes at http://www.typensave.com, pressing tab
will move the cursor to an empty field, but focus is lost and typeing does not
fill in the field.

Reproducible: Always

Steps to Reproduce:
1. Log in at http://www.typensave.com (use any name as Contributor Name,
"mozilla" as Group Login, and "3df5c" as Password).
2. Click on "add recipe".
3. Use tab to move between elements as filling out form.

Actual Results:  
On certain fields, the cursor will appear in the field but anything typed does
not appear unless you click on the field first.  If "Find As You Type" is turned
on, it will kick in and capture any keypresses, moving you elsewhere on the page.

Expected Results:  
Typing should appear in the field without clicking.

This page works fine in IE 5.  If it is bad coding and not a bug in Mozilla, I
am sure they will listen if someone will tell them how to fix it without
breaking IE.  They responded very quickly when I let them know their browser
sniffer was blocking Mozilla running on Linux.

Comment 1

15 years ago
It seems to me that all the fields /work/ by tabbing through, but some of them
*appear* selected when they really aren't, Ie. after tabbing out of one
category, focus (correctly) shifts to the javascript help button below it, but a
cursor also (incorrectly) starts blinking in the next category.

This behaviour on 1.5a Linux

Comment 2

15 years ago
Created attachment 130346 [details]
testcase

with linux trunk 2003081822:
1. click in the first textbox
2. tab

caret appears in the second textbox, but focus is actually still on the "foo"
link.

Comment 3

15 years ago
dupe of "javascript focus() only moves the cursor not the focus"

*** This bug has been marked as a duplicate of 147927 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: testcase
OS: Windows 98 → All
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.