If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash if I close last mozilla window, when mail client during work wasn't able to establish connection to POP mail server

RESOLVED WORKSFORME

Status

MailNews Core
Networking: POP
--
critical
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Jaroslav Mervart, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

When mail client sometimes cannot connect to server, and writes a error message
(cannot establish a connection... or similar), there is a problem with closing
mozilla application. When I close last window, computer crashes, and after
restart (and scandisk action) prefs.js file (and maybe more opened files) is
damaged (no account information is aviable - you must create new account). There
is also problem with creating account - new account is not created (maybe unable
to rewrite damaged file) - and with next start of Mozilla, I have to create new
account again. I find out that in this situation is neccesary to delete prefs.js
file, and then is Mozilla able to remember profile info permanently, and create
a new prefs.js file.

Reproducible: Always

Steps to Reproduce:
1. start mozilla
2. sometimes during work, mozilla cannot connect to mail server, and writes and
error message about it (or sometimes I have to press stop, because of no action
- no results about server status, still trying to connect - this happens with
previous beta version)
3. I work with Internet for a few minutes (hours) with no problem
4. when I closed last mozilla window system crashes (restarts)
5. scadisk before starting windows xp home
6. When I tried to start Mozilla I get an error message about damaged prefs.js
file and I have no profile - no access to mail server
7. I have to create a new account (unpossible without deleting damaged prefs.js
file)



Expected Results:  
No crashes, even if the mail app have problem with connection to server.

It happens with previous versions of mozilla too.

Comment 1

14 years ago
Jaroslav: Could you retest it with actual nightbuild? If Mozilla still crash,
please provide TalkBack incident ID.
Keywords: crash
Product: MailNews → Core

Comment 2

13 years ago
No response from reporter for several months, marking WFM.
Reporter: Please reopen this bug, if you could reproduce with recent build and
could provide Talkback incident ID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.