new profile can use existing profile directory that was renamed

VERIFIED DUPLICATE of bug 57464

Status

Core Graveyard
Profile: BackEnd
VERIFIED DUPLICATE of bug 57464
15 years ago
2 years ago

People

(Reporter: Hidehiro Kozawa, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; ja-JP; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; ja-JP; rv:1.5a) Gecko/20030718

New profile can use existing profile directory that was renamed.

Reproducible: Always

Steps to Reproduce:
1.New profile "Default User" create.
2.Profile "Default User" rename to "renamed".
3.New profile "Default User" create.


Actual Results:  
Both profile "renamed" and "Default User" use same profile directory.

Expected Results:  
When new profile name is existing profile directory, at creating new profile,
new profile creating failed or new profile directory name has name with postfix.


If "renamed" profile will delete, profile "Default User" becomes invalid.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 57464 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.