Wanted: man-/info-page browser (man:/info: URL handler)

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
15 years ago
12 years ago

People

(Reporter: toralf, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Another quite useful feature of Galeon (that keeps me from switching to
thunderbird) is the ability to browse system documentation via special URLs;
when entering man:<topic>[.<section>] it will essentially execute

man [<section.] <topic> | man2html

and display the resulting HTML code. info:<topic> produces similar results, but
info2html is executed instead.



Reproducible: Always

Steps to Reproduce:





Might perhaps be implemented as an Extension.
(Reporter)

Comment 1

15 years ago
And "ghelp:" (= GNOME help files) may perhaps be supported, too.

The effect may be simulated via Bookmark keywords, but that will require a
server providing a man or info page to HTML gateway, which won't always be
available.

Updated

15 years ago
Severity: normal → enhancement

Comment 2

15 years ago
Since Firebird is not a platform-specific browser like Galeon or K-Meleon,
platform-specific functionality is considered unnecessary bloat (with the
exception of UI functionality).

-> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED

Comment 3

14 years ago
*** Bug 296179 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
Do you know if someone is working on a Firefox extension to read the man / info
pages ?
(Reporter)

Comment 6

14 years ago
Yeah, maybe an extension would be nice - but I don't know of such a project...

I've also been thinking that this kind of thing might be implemented through
some kind of url-to-command filter. What I have in mind is a mechanism that
would allow me to say to Firefox "whenever you encounter an URL of the form
<someprotocol>:<path>, please run <somecommand> <path> and display its standard
output in the browser window."

Maybe we should add a separate feature request for that.
(Reporter)

Comment 7

14 years ago
See bug 296208...

Updated

12 years ago
Duplicate of this bug: 369849
You need to log in before you can comment on or make changes to this bug.