hover effect broken on 'float: left' A withing DIV that has 'display: table' set.

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Ruud van Melick, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20030117 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20030117 Phoenix/0.5

In the URL then demonstrates the problem, the hover effect does not work if <DIV
style="display: table"> surrounds <A style="float: left; display: block">, while
all other style settings for A work fine.

Reproducible: Always

Steps to Reproduce:
See demonstration URL.
Actual Results:  
No hover effect.

Expected Results:  
Change color of <a> when mouse is over <a>

Tested with Mozilla 1.3 (linux), Mozilla 1.4 (linux), Mozilla 1.5a (windows).

Comment 1

15 years ago
Created attachment 130371 [details]
Testcase

Comment 2

15 years ago
Confirming bug, 2003-08-24-05 trunk Linux.  Maybe it belongs to Layout:Tables
though?  Bug does not occur for regular HTML table, only for CSS.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 3

15 years ago
Created attachment 130374 [details]
Testcase #2

It seems the problem only occurs if the 'table-cell' element is anonymous.
Yeah, sounds like a bug in table frame construction...
Assignee: core.layout.floats → nobody
Component: Layout: Floats → Layout: Tables
QA Contact: ian → core.layout.tables
It seems to be fixed somehow.
I can reproduce the bug in Mozilla1.6.
however, I can't reproduce it anymore in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; @AB_CD@; rv:1.8a4) Gecko/20040924
Firefox/0.9.1+

Comment 6

14 years ago
wfm winxp 2004092206
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.