Message Total out of synch

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: mozillastuff, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

The message Total is gradually going  out of synch with the actual in the
(Inbox) folder.

I have this occuring for most users with versions 1.3 to 1.4 seems to occur
after prolonged use but haven't been able to actually duplicate it with a test.

CGate Pro IMAP Server on Linux
Clients NT4, WIndows2000
Mozilla versions 1.3 to 1.4

nothing seems wrong server side the actual messages displayed are correct just
the total is wrong.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




All are set to move deleted messages to Trash
-> Database
Assignee: sspitzer → bienvenu
Component: Mail Window Front End → Mail Database
(Assignee)

Comment 2

15 years ago
this is most likely a dup of other bugs that I can't reproduce. Do you ever
access the INBOX with an other e-mail client or from another machine at the same
time as you're accessing it with Mozilla? In which direction is the inbox count
getting off? Does Mozilla say you have more messages than you do, or less? My
guess is more. Does the unread count get off as well, or just the total count?

If you switch to threaded view, do you see threads that have the wrong message
count in them? That's assuming you have a small enough inbox to look at all the
messages...
Status: UNCONFIRMED → NEW
Component: Mail Database → Networking: IMAP
Ever confirmed: true
(Reporter)

Comment 3

15 years ago
Mozilla always has more messages

--

We do not access the INBOX with an other e-mail client or from another machine
at the same time.

Exceptions are
email notification aps which the check the Inbox for unread messages.
When serveral instances of mozilla.exe running at the same time (not intended
but happens)

--
It is just the total count. Unread is correct.

--
Thread totals are correct
(Assignee)

Comment 4

15 years ago
you should never get multiple instances of mozilla running at the same time, but
if you do, against the same profile, you will have all sorts of problems.

what kind of imap server are you using? And what is the notification app? If you
delete the .msf file, I assume the count is corrected? I'll try to put some
auto-correction code in the imap code, but I'd like to know what causes things
to go wrong.

Comment 5

15 years ago
I can confirm this problem here as well using various versions of Mozilla (1.4.1
on Linux, 1.5-alpha and a recent nightly on windowsXP).
Server is courier-imap 2.1.1. The mailboxes in question are often accessed from
different machines and platforms, and mozilla seems to show always more for the
message total.
(Assignee)

Comment 6

15 years ago
*** Bug 217650 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 7

15 years ago
Hi David

Notification tool is IMAP Notify from:
ftp://ftp.vandyke.com/pub/IMAPNotify/
(Which just checks the mailbox for unread messages)

Server is ComminuniGate Pro IMAP Server on Linux
http://www.stalker.com

The problem occurs even if there has not been multiple instances of mozilla.exe
running.

yes removing / regeneration of the .msf file returns total to correct value.
(Assignee)

Comment 8

15 years ago
Created attachment 130785 [details] [diff] [review]
potential fix

The only theory I can come up with so far is that we're downloading (or think
we're downloading) the hdrs for a message we already have. This will result in
the  total count getting off. This patch has some cleanup, and adds a check
that we don't already have the hdr for a message in the db before adding the
hdr to the db.
(Assignee)

Updated

15 years ago
Attachment #130785 - Flags: superreview?(scott)

Comment 9

15 years ago
Comment on attachment 130785 [details] [diff] [review]
potential fix

hopefully this will fix it =)
Attachment #130785 - Flags: superreview?(scott) → superreview+
(Assignee)

Comment 10

15 years ago
this fix is checked into 1.6 - we'll need people to try 1.6 and see if this
really fixes it.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.