span or div with display: inline does not allow to set size through width and height styles

RESOLVED DUPLICATE of bug 50626

Status

()

Core
Layout: Block and Inline
RESOLVED DUPLICATE of bug 50626
15 years ago
13 years ago

People

(Reporter: Vladimir Eltchinov, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Mozilla ignores width an height styles in <span> and in <div> with display:inline.

Reproducible: Always

Steps to Reproduce:
1. open a page wudth the next code
Before<div style="background-color: #00ff00; width: 100px; height: 100px;
display: inline;">Some text</div>After<br>
Before<span style="background-color: #00ff00; width: 100px; height: 100px;">Some
text</span>After<br>

Actual Results:  
To strings BeforeSome textAfter  where Some text" is on green background

Expected Results:  
In one line - "Before", green square 100x100 with word "Some text" inside, "After"

<div> with no display style works as expected - shows 100x100 square and breaks
the line. IE works as expected.
IE's behavior is a bug.  'width' and 'height' don't apply to inline elements. 
WinIE magically changes some elements to inline-block.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
Created attachment 130399 [details]
Test case
(Reporter)

Comment 3

15 years ago
Created attachment 130401 [details]
Test case in Mozilla
(Reporter)

Comment 4

15 years ago
Created attachment 130402 [details]
Test case - expected behaviour (IE)

Comment 5

15 years ago
v. invalid.
Status: RESOLVED → VERIFIED
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 50626 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.