crash then I open any message while IMAP

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
critical
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Alex Porollo, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.4) Gecko/20030624

The bug under OS/2 Warp 4.5
Intranet mail server MS Exchange 5.5 SP4


Reproducible: Always

Steps to Reproduce:
1.Open Mail & Newsgroup component
2.Select our general folder
3.Scan any mail folder
4.Select any message

Actual Results:  
Crash.

POPUPLOG.OS2:
-------------
08-26-2003  15:15:57  SYS3175  PID 009f  TID 0001  Slot 00ef
C:\MOZILLA\MOZILLA.EXE
c0000005
1d3f4e50
P1=00000001  P2=043e0440  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=043e0440  EBX=0037c038  ECX=00000000  EDX=043e0440
ESI=0037c038  EDI=00000002  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d3f4e50  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00150654  SSACC=f0f3  SSLIM=ffffffff
EBP=00150680  FLG=00012212

MOZJS.DLL 0001:00054e50




Example of message:
-------------------

Received: by exchsrv.xxx.ru 
        id <01C36B09.F4B4BFA0@exchsrv.xxx.ru>; Mon, 25 Aug 2003 17:08:20 +0400
Message-ID: <04093979ADC3D61197DB60561E00000002CF21@EXCHSTAV01>
From: =?KOI8-R?Q?=E7=C1=C5=D7=D3=CB=C9=CA_=E1=CC=C5=CB=D3=C1=CE=C4=D2_=E9?=
        =?KOI8-R?Q?=D7=C1=CE=CF=D7=C9=DE?= <gai@stavropol.xxx.ru>
Subject: =?KOI8-R?Q?=EB=CF=CE=D4=D2=CF=CC=D8=CE=C1=D1_=D3=D5=CD=CD=C1?=
Date: Mon, 25 Aug 2003 17:08:20 +0400
Return-Receipt-To: =?KOI8-R?Q?=E7=C1=C5=D7=D3=CB=C9=CA_=E1=CC=C5=CB=D3=C1?=
        =?KOI8-R?Q?=CE=C4=D2_=E9=D7=C1=CE=CF=D7=C9=DE?= <gai@stavropol.xxx.ru>
MIME-Version: 1.0
Content-Type: text/plain;
        charset="KOI8-R"
Content-Transfer-Encoding: base64

9dfB1sHFzdnFIMfP09DPxMEhDQrtz9bF1CDL1M8tzsnC1cTYINDPxNPLwdbF1CDLwcvPxSDVIM7B
0yANCsnNxcXU09EgzMnDxc7aydLP18HOzs/FIPDvINDPINLB097F1NUgDQrLz87U0s/M2M7PyiDT
1c3N2SDGwcrMwSjGwcrMz9cpPw0KUC5TLiD2xczB1MXM2M7PINDPIFdpbjMyDQoNCvMg1dfB1sXO
ycXNIOHMxcvTwc7E0i4NCg==

Comment 1

15 years ago
reassigning; don't know why this bug came to me

mitchell
Assignee: mitchell → scott

Comment 2

15 years ago
.
Assignee: scott → sspitzer
Component: Miscellaneous → Mail Back End
Product: mozilla.org → MailNews
QA Contact: mitchell → esther
Version: other → 1.0 Branch

Updated

15 years ago
Severity: normal → critical
Keywords: crash
Reporter: could you please try this using a recent nightly build from
<http://ftp.mozilla.org/pub/mozilla/nightly/latest/> ? If it works, please
resolve this bug as WFM. Thanks !
OS: other → OS/2
Version: 1.0 Branch → Trunk

Comment 4

15 years ago
can you zip up an inbox that crashes and post it?

Thanks

Comment 5

15 years ago
Reporter, for all post-1.4 OS/2 builds, visit and read
http://www.mozilla.org/ports/os2/ before installing. Note that these newer
builds depend on two files that are not included in the public zip or installer.
If you use 1.4 release or the 1.4 nightlies you don't need these two files.
(Reporter)

Comment 6

15 years ago
On Wed, 27 Aug 2003 19:30:44 +0200, Vidar Braut Haarr wrote:

>Follow these steps:
>1. Delete the Profile directory.
>2. Delete the Mozilla directory.
Erased the whole c:\mozilla directory.

>3. Install Mozilla (todays nightly build).
27.08.03   9:44   15933812             0  mozilla-i386-pc-os2-emx.zip
There are no more recent builds.

>4. Try again.

4.1 If I have c:\os2\nsreg.dat from NC4.61 we have:
4.1.1 start mozilla.exe
4.1.2 ask about converting nc4 profile
4.1.3 Press "Manage Profile..."
4.1.4 Exit with out any actions.
4.1.5 start mozilla.exe
4.1.6 POPUPLOG.OS2:
08-28-2003  09:41:11  SYS3180  PID 00db  TID 0001  Slot 00d9
C:\MOZILLA\MOZILLA.EXE
c0000097
1d7ef635
EAX=7fe00c62  EBX=ffffffff  ECX=0006f888  EDX=00000001
ESI=7fefffff  EDI=0031d650  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d7ef635  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0006f850  SSACC=f0f3  SSLIM=ffffffff
EBP=0006f868  FLG=00002a87

MOZJS.DLL 0001:0002f635

4.2 Now:
del C:\Mozilla\Mozilla\*
del C:\Mozilla\components\*.dat
or
erase C:\Mozilla at all with restoring from archive.
and
ren c:\os2\nsreg.dat c:\os2\nsreg_.dat

4.2.1 start mozilla.exe
4.2.2 just only exit without any change of preferences. See that new default 
profile and nsreg.dat have been created.
4.2.3 start mozilla.exe
4.2.4 POPUPLOG.OS2:

08-28-2003  09:48:42  SYS3180  PID 00df  TID 0001  Slot 00d9
C:\MOZILLA\MOZILLA.EXE
c0000097
1d7ef635
EAX=7fe00c62  EBX=ffffffff  ECX=0006f888  EDX=00000001
ESI=7fefffff  EDI=0031d650  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d7ef635  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0006f850  SSACC=f0f3  SSLIM=ffffffff
EBP=0006f868  FLG=00002a87

MOZJS.DLL 0001:0002f635

>Does it work then ?

You see :-(

5. Now I try:
3.07.03   8:41   17333022             0  mozilla-os2-vacpp-1.4-installer.exe
5.1 Do 4.2 - 4.2.3
5.2 It start.
5.3 Manage mail profile with IMAP
5.4 See any message and have:
POPUPLOG.OS2:

08-28-2003  10:06:38  SYS3175  PID 00ec  TID 0001  Slot 00dd
C:\MOZILLA\MOZILLA.EXE
c0000005
1d754e50
P1=00000001  P2=772f2f3a  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=772f2f3a  EBX=0037bac0  ECX=00000000  EDX=772f2f3a
ESI=0037bac0  EDI=00000001  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d754e50  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00150654  SSACC=f0f3  SSLIM=ffffffff
EBP=00150680  FLG=00012212

MOZJS.DLL 0001:00054e50

Comment 7

15 years ago
This is a crash in js_strlen. probably a null ptr.

This happens viewing any IMAP message or just specific ones?

Short of accessing your account, I'm not sure what I can do.

Our IMAp server is working fine....

(Reporter)

Comment 8

15 years ago
>This is a crash in js_strlen. probably a null ptr.
>This happens viewing any IMAP message or just specific ones?

About 9 of 10 messages.

>Short of accessing your account, I'm not sure what I can do.

This is intranet account.

>Our IMAp server is working fine....

I tested Mozilla 1.3/1.4 for win32. It one work fine with that IMAP server.
In that case this is a problem of OS/2 builds.

Comment 9

14 years ago
Is this still happening? can you possibly send one of the crashing emails to
testing@kaply.com?

Comment 10

14 years ago
Are you still seeing this?
(Reporter)

Comment 11

14 years ago
Yes :-(
With mozilla 1.5 release and 1.6a.
(Reporter)

Comment 12

14 years ago
May be anybody can give me a special debug version of Mozilla that can show 
more information about trap in mozjs.dll?
Thunderbird v0.3 similar dies on the same dll.

Comment 13

14 years ago
What I need is the email message that crashes.

I bet a particular message is causing the trap.

send it to testing@kaply.com.

If you run a particular milestone build (like 1.5) I can send a logging version
of MOZJS.DLL.

Comment 14

14 years ago
Do you still have this problem?
(Reporter)

Comment 15

14 years ago
Yes :-(
With Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.6) Gecko/20040117
And with Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.5) Gecko/20031015 
Firebird/0.7
And with Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7a) Gecko/20040210

With last one:
02-12-2004  09:14:35  SYS3175  PID 00c2  TID 0001  Slot 00e5
C:\MOZILLA\MOZILLA.EXE
c0000005
1d7e250e
P1=00000001  P2=bdd0208f  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=bdd0208f  EBX=013c570c  ECX=0013f06a  EDX=bdd0208f
ESI=00000000  EDI=0013f154  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d7e250e  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0013edfc  SSACC=f0f3  SSLIM=ffffffff
EBP=0013edfc  FLG=00012212

MOZJS.DLL 0001:0005250e


I asked for debug version, but nobody can give it to me.

Comment 16

14 years ago
So what version of Mozilla are you running right now?
(Reporter)

Comment 17

14 years ago
Right now I am running:
Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7a) Gecko/20040210
(Reporter)

Comment 18

14 years ago
Yes! I have changed only:
Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7b) Gecko/20040325
23.02.04 15:44 356274 libc05.dll
23.02.04 15:40 28718 gcc322.dll
and have left my own profile. And now IMAP support is working excellently!
This bug have been resolved.
Mozilla 1.7a and lower builds do not work as before.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 19

14 years ago
Reporter, FIXED is not an appropriate resolution for this bug. Please read
http://www.mozilla.org/quality/help/bugzilla-privilege-guide.html#resolving and
resolve correctly.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 20

14 years ago
WFM is the right resolution.

This is great news.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
(Reporter)

Comment 21

12 years ago
The Mozilla writes very very long path names like:
C:\Mozilla\Mozilla\Profiles\ap\2i0swqqt.slt\ImapMail\server.test.aaa.ru\&BB4EMQRJBDgENQ- &BD8EMAQ,BDoEOA-.sbd\&BBoEPgQ9BEQENQRABDUEPQRGBDgEOA-.sbd\&BB8EQAQ+BDMEQAQwBDwEPAQ9BD4ENQ- &BD4EMQQ1BEEEP1ddb8cd2.sbd\&BCAEMAQ3BEAEMAQxBD4EQgQ6BDA- &BB8EHg-.sbd\Perl.msf
The os2`s hpfs(386) and jfs have a limitation of path length.
If I try to subscribe the more long imap name, I have the crash of Mozilla.
Windows (NT clone) and Linux have no this problem with them FS.

P.S. The names are in ASCII 128-255.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
The filename issue is a different issue from the original one and should have a new bug opened rather than reopen this one.  Windows does have the same filename restriction, 255 characters if I recall correctly on windows.  The difference seems to be the way that the restriction is handled.  On windows it will allow you to save a file that exceeds this limit but I have to walk people through renaming lower level directories to get the pathname down so that it can be used.

Comment 23

11 years ago
As Andy said, the filename length problem is another one. You are welcome to open a new bug on that.
(Marking WFM again for the original bug.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago11 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.