Proxy username and password dialogue does not always appear

VERIFIED WORKSFORME

Status

()

--
major
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: camrat, Assigned: darin.moz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [proxy])

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I connect to the internet in work through a proxy server.  When I launch M$ 
internet exploder it always displays a dialogue asking me for my connection 
credentials and then will proceed to let me use the internet.  Mozilla too 
presents me with a dialogue asking for my connection credentials - but only 
some of the time - approx 1 out of 10 times!  Some days it will not ask me at 
all and just presents me with an alert box with the following message:  "The 
connection was refused when attempting to contact www.mozilla.org".  It's not 
just mozilla - it is ANY website at all.

Reproducible: Sometimes

Steps to Reproduce:
1. Require proxy authentication to access the web
2. Try to connect requiring the proxy authentication
3. Try closing Mozilla and re-opening it at various stages

Actual Results:  
I get a connection refused alert box instead of the dialogue asking me for the 
proxy credentials.

Expected Results:  
Presented me with the dialogue box requesting proxy authentication and 
proceeded to let me browse the web.  I cannot find anywhere to force Mozilla to 
ask me for proxy details.  Maybe it is being TOO user friendly ??

Comment 1

16 years ago
can you try latest nightly build ?
http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk

If issue still occur, please post a HTTP log from a minimal session via 'create
a new attachment', see instructions here:
http://www.mozilla.org/projects/netlib/http/http-debugging.html
Assignee: ccarlen → darin
Severity: blocker → major
Component: Preferences: Backend → Networking: HTTP
QA Contact: sairuh → httpqa
Whiteboard: [proxy]

Comment 2

14 years ago
Same problem here. With Firefox 1.0 (20041115).
I need to connect through the college proxy server to access some articles on
research journals.
With IE everything ok. Before displaying first page it asks for user/pwd.
With Firefox, nothing... well, the curious fact is that with the "Automatic
proxy configuration URL" active I can navigate but not through the proxy. (I
know it because when I connect to www.sciencedirect.com with IE it identify me
as if I were connecting through my college).

Comment 3

14 years ago
Gorka, does this happen w/ a new profile?

Do you know what kind of proxy you are using?
Summary: Proxy username and password request dialogue does not appear most of the time → Proxy username and password dialogue does not always appear

Comment 4

14 years ago
After the problems, I tried the trunk and with it everything was fine.
Now, I try a new 1.0 installation from scratch and everything is just fine. I
thought it was a clean installation before... (november).

Sorry then for the false alarm... :(

G.

Comment 5

14 years ago
Keith, how about you?
QA Contact: networking.http → benc
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 7

13 years ago
Apologies - same result as Gorka.

Thanks for your assistance all.


This can be closed now as far as i'm concerned.

Many thanks
Keith.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
bugs for which no code changes were done are worksforme, not fixed
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME

Comment 9

13 years ago
V/wfm.
Status: RESOLVED → VERIFIED

Updated

13 years ago
Component: Networking: HTTP → Networking
You need to log in before you can comment on or make changes to this bug.