Lines of text are cut off on top or bottom on pages with small fonts

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
16 years ago
2 years ago

People

(Reporter: torstie, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)
Build Identifier: 1.4-17

On pages like at the example URL (but not limited to it), random lines of text 
will be cut off on top or bottom. For example, a capital O might look much like 
a non-capitalized u because of the cut off.

Once the lines is selected with the mouse and double-clicked, the problem 
disappears for this one line, but not the others.

I've personally noticed this in Versions 1.4-7 up to 1.4-17, and others have 
experienced the same problem.

Reproducible: Always

Steps to Reproduce:
1. Setup of SuSE Linux 8.2 Professional, auto-detection of screen and auto-
installation of x-server.
2. Installation of Mozilla rpm file from rpmseek.com. (1.4-7 or 1.4-17 for SuSE 
8.1/8.2)
3. Open example web page, scroll up and down.
Actual Results:  
Text of posting cut off on several, random lines.

Expected Results:  
Display of whole letters on all lines.

Comment 1

16 years ago
Asa,
 I'm getting more and more of these bugs, which shouldn't be coming to me.  Can
we change this?

mitchell
Assignee: mitchell → asa

Comment 2

15 years ago
wrong component
Assignee: asa → general
Component: Miscellaneous → Browser-General
Product: mozilla.org → Browser
QA Contact: mitchell → general
Version: other → Trunk

Comment 3

15 years ago
Created attachment 137886 [details]
screenshot demonstrating problem

This is a screenshot from Sunsolve demonstrating the bug.

Comment 4

15 years ago
Created attachment 137887 [details]
zoomed in screenshot

Notice how some lines have tops and/or bottoms of fonts cut off.  Another line,
4748411, has a row of pixels missing between the bottom of the "4" character
and the horizontal line in the "4", as if the letters have been squished.

Comment 5

15 years ago
The screenshots I just attached were from Mozilla 1.5 on Solaris 8 through a
SunRay thin client.   I was viewing the README from patch 108528-27 at this page:
http://sunsolve.sun.com/pub-cgi/retrieve.pl?doc=fpatches%2F108528&zone_32=108528

The fonts only get cut off or squished when scrolling.  If I highlight the text
or otherwise force a refresh of the screen (minimize the window and open it
again), the fonts look fine.
  

Comment 6

15 years ago
WFM in SuSE 8.2 with 1.6.

Comment 7

14 years ago
I am seing this too with FireFox 1.0 (Linux/Suse9.1/KDE3.3.1).

In an attempt to put things together, I am listing here bug reports that seem
related to me. Sorry for not doing more analysis (and reading all the comments
of all bugs listed here) or for the bugspam but I really think this linking
might be useful. Please note that this bug is listed too (as I put the same in
different bugs).

bug 172162 Linux
bug 174977 All (was Solaris)
bug 199840 Linux
bug 211704 Linux
bug 215759 Linux
bug 217336 Linux
bug 217825 All (was Linux)
bug 228808 MacOS X
bug 248799 Linux

I built this list by searching for scroll and font in the comments from newest
to oldest going up to the first one of this list (feel free to search further)
and I might have missed some.

I put the OS as it seems there is a link between them: is it due to the usage of
a common deployed library, a bug in an OS' library, ...?
Product: Browser → Seamonkey

Comment 8

14 years ago
In my present build of Mozilla (20050224), the example given above seems to
display perfectly. But have a look at British Telecom's Directory Enquiry site
and enter a search name with several findings, and the lines do not display
fully; for example go to <http://www.bt.com/directory-enquiries/dq_home.jsp>,
choose 'Business', enter 'Luton Airport' and on the next page click 'Bedfordshire'.

I have seen this on numerous sites. It does not happen with Internet Explorer.

For the record, I am using an eMac G4 with OS 10.3.8 and Classic theme. 

Comment 9

14 years ago
Moving to Layout:Text
Component: General → Layout: Fonts and Text
Product: Mozilla Application Suite → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Updated

13 years ago
Assignee: general → nobody
QA Contact: general → layout.fonts-and-text

Comment 11

2 years ago
It's 2017 and this bug is still present, happens randomly but still showing up...

https://www.dropbox.com/s/9dk0xgoj1fj41eb/Capture.PNG?dl=0
You need to log in before you can comment on or make changes to this bug.