Closed Bug 217348 Opened 16 years ago Closed 11 years ago

Inconsistent accesskeys for Add/Remove buttons on Send Options dialog

Categories

(Thunderbird :: Preferences, defect, P4, trivial)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: jhenry, Assigned: philor)

References

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030826 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030826 Mozilla Firebird/0.6.1+

This is a minor UI inconsistency brought about by how MailNews handled Plain
Text vs. HTML domains.

In the Mozilla suite' MailNews, the Send Format option page has the Plain Text
and HTML Domain lists on the same page, and each list has its own Add/Delete
buttons. Under HTML Domains, the hotkey for Add is A and the one for Delete is
L. Under Plain Text Domains Add's hotkey is D and Delete's is T. However,
Thunderbird puts the two lists on different tabs, making the two sets of hotkeys
unnecessary and confusing (D for Add). I'd suggest giving both pairs of buttons
the same hotkeys (simply Alt-A for Add and Alt-D for Delete).

Reproducible: Always

Steps to Reproduce:
1. Open Options/Composition/Send Options.
2. Note the different sets of hotkeys for the two pairs of buttons.

Actual Results:  
Each pair has its own set of hotkeys.

Expected Results:  
The same hotkeys should always refer to Add and Delete throughout Thunderbird's UI.
i agree. fix checked in.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird0.2
The accesskeys don't work for me now.  ^A only works when the Plain Text tab is
selected; ^D only focuses the button and doesn't display the prompt.  Neither
accesskey works inside the HTML tab.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
backed out and pushing off. Thanks for catching that Stephen.
Status: REOPENED → ASSIGNED
Target Milestone: Thunderbird0.2 → After Thunderbird 1.
Depends on: 143065
I don't think I really backed this out. Looks like it made its way into 0.2!!!

*doh*

bringing back in until i remember to back this out for real.
Target Milestone: After Thunderbird 1. → Thunderbird0.3
I don't see this in 0.2 (windows)...?
Even if it's there, it won't be a big issue.
QA Contact: asa
Target Milestone: Thunderbird0.3 → Thunderbird0.4
Target Milestone: Thunderbird0.4 → Thunderbird0.6
Attached patch proposed patch (obsolete) — Splinter Review
My second attempt at a patch.  I couldn't get the buttons to have the same
accesskey at the same time so it is assigned on tabswitching.
Whoops, didn't see the depends.  I guess this can be a temporarily fix?  (Sorry
for the bugspam)
pushing off, I don't think synching up the accessor keys is worth the complexity
of dynamically changing the access keys... 
Target Milestone: Thunderbird0.6 → Thunderbird0.9
*** Bug 250226 has been marked as a duplicate of this bug. ***
Target Milestone: Thunderbird0.9 → Thunderbird1.1
Blocks: 260726
No longer blocks: 260726
*** Bug 260726 has been marked as a duplicate of this bug. ***
Target Milestone: Thunderbird1.1 → Thunderbird1.5
mod summary - these are access, accessor or accellerate keys (not sure of the
precisely correct term), not hot keys

Not comfortable removing it - shouldn't this target milestone be removed?
Severity: minor → trivial
OS: Windows 2000 → All
Hardware: PC → All
Summary: Inconsistent hotkeys for Add/Remove buttons on Send Options dialog → Inconsistent accessor for Add/Remove buttons on Send Options dialog
QA Contact: preferences
I don't see this in Mac Leopard 2.0.0.12, Options/Composition/Send Options doesn't have hotkeys for the 2 sets of buttons.

Wayne, still valid for Windows?
Whiteboard: CLOSEME 2008-04-30
Assignee: mscott → philringnalda
Status: ASSIGNED → NEW
Summary: Inconsistent accessor for Add/Remove buttons on Send Options dialog → Inconsistent accesskeys for Add/Remove buttons on Send Options dialog
Whiteboard: CLOSEME 2008-04-30
Target Milestone: Thunderbird1.5 → Thunderbird 3
Version: unspecified → Trunk
the patch of course never checked in.  My first re-read is I think the prefs UI has changed since comment 0. If that's correct then the bug is invalid.  I'll leave it to you decide.
The fact that I assigned it to myself is a strong hint that it is not invalid.

STR:
1. Open Tbird preferences/options
2. Go to the Composition pane
3. Click the Send Options... button
4. Be sure the HTML Domains tab is selected
5. Note that the accesskeys for the Add and Delete buttons are "A" and "l" (worst key ever)
6. Select the Plain Text Domains tab
7. Note that the accesskeys for the Add and Delete buttons are "d" and "t"
8. Note that the blocking bug, bug 143065, is now resolved fixed, making it possible to have the same accesskeys in different tabs within a single prefwindow.
Attachment #144361 - Attachment is obsolete: true
Priority: -- → P4
Attached patch Fix v.1Splinter Review
Yay for accesskey changes, where I don't have to change entity names (and would annoy the locales that have already fixed these, if I did).
Attachment #343858 - Flags: review?(mkmelin+mozilla)
Status: NEW → ASSIGNED
Comment on attachment 343858 [details] [diff] [review]
Fix v.1

Nice, r=mkmelin
Attachment #343858 - Flags: review?(mkmelin+mozilla) → review+
http://hg.mozilla.org/comm-central/rev/3c28c613fa2a
Status: ASSIGNED → RESOLVED
Closed: 16 years ago11 years ago
Resolution: --- → FIXED
Target Milestone: Thunderbird 3 → Thunderbird 3.0b1
You need to log in before you can comment on or make changes to this bug.