Menus on the left side of this page are unreadable

VERIFIED WORKSFORME

Status

SeaMonkey
General
VERIFIED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Michael Baffoni, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

When I go to this page, I can't see the menu items that are presented on the
left.  When I view this page on IE 6, or Netscape 4.8 it looks fine.  Changing
my prefbar to IE6 or NS4.7 doesn't seem to help, nor does specifying system
colors (in case it was a blue on blue text issue).

Reproducible: Always

Steps to Reproduce:
1.Go to the website
2.Look at the menus on the left


Actual Results:  
3.They don't work in NS7.1 or Moz1.4, they work fine in IE6 and NS4.8

Expected Results:  
You should see the menus like you see them in IE6 and NS4.8
(Reporter)

Updated

14 years ago
Keywords: 4xp

Comment 1

14 years ago
I'm pretty sure this is a tech evanglism thing... checking out the page in DOM I
i see div elements with:

clip:rect(0pt, 136px, 25px, 0pt);
width:136px;
height:25px;

given:
http://www.w3.org/TR/REC-CSS2/visufx.html#clipping
In CSS2, the only valid <shape> value is: rect (<top> <right> <bottom> <left>)
where <top>, <bottom> <right>, and <left> specify offsets from the respective
sides of the box.

it looks like the boxes are getting clipped pretty bad.

but its late and i'd like a 2nd set of eyes as i'm not sure i'm hitting the
proper elements and what have you
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 2

14 years ago
Did anyone have a chance to verify this analysis is correct?  Any idea why IE
and NS4.8 are rendering properly if the code is wrong?

Comment 3

14 years ago
My best guess is that the JavaScript is out of whack, although I only have a
couple minutes to look just now. It does some fairly complicated browser
detection, however it doesn't seem to support anything higher than Netscape 5
(which is a tad odd, since Netscape 5 doesn't exist...). IE and NS4 render
correctly because the script is able to detect them and send them code that is
non-standard but understood by them. But the site is incorrectly identifying
Mozilla as some older version of Netscape (I think) and sending it badly broken
code that it chokes on. That's my 5 minute analysis, this is probably something
for Tech Evangelism.
Product: Browser → Seamonkey

Comment 4

12 years ago
WFM SM trunk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

12 years ago
Confirming.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.