Closed Bug 217358 Opened 18 years ago Closed 18 years ago

Chatzilla should use prompt service instead of alert

Categories

(Other Applications :: ChatZilla, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hjtoi-bugzilla, Assigned: bugzilla-mozilla-20000923)

Details

(Whiteboard: cz-patch)

Attachments

(1 file)

One of our UI guidelines is to use the prompt service instead of alert(). I
can't remember the exact reasoning, but maybe alert() in chrome locks the whole
app or something.

See p3p for an example on how to use the prompt service.
According to #mozilla, "prompt service dialogs are distinguished as
trustworthy," whatever that means. :)  We can at least set the title on them to
something sensible, rather than "Alert".

--> Taking.
Assignee: rginda → silver
D'oh, silly Bugzilla.
Status: NEW → ASSIGNED
http://lxr.mozilla.org/mozilla/source/extensions/venkman/resources/content/venkman-utils.js#226

You should just need to add the alert, confirm, and prompt functions from
venkman-utils.js into chatzilla's utils.js
This patch just adds the Venkman alert/confirm/prompt functions, as suggested
by rginda. I have confirmed that calls from the *client* tab are now using
these functions, but couldn't check Chatzilla itself because bug 213782.
Whiteboard: cz-patch
Comment on attachment 131628 [details] [diff] [review]
"Borrow" from Venkman

r=rginda
Attachment #131628 - Flags: review+
fixed in 0.9.40
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.