weightwatchers.com - reject Mozilla and Netscape 7.1

RESOLVED DUPLICATE of bug 165257

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED DUPLICATE of bug 165257
15 years ago
3 years ago

People

(Reporter: prather, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

The e-tools login will not recognize Mozilla 0.6 or Netscape 7.1.  I have
complained to them (twice) and reported the problem to Netscape. The site will
work if spoofed.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
confirm
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All
Summary: Will not accept Mozilla 0.6 or Netscape 7.1 → weightwatchers.com - reject Mozilla and Netscape 7.1

Comment 2

15 years ago
The browser detect script used throughout the site simply checks browser version
number, and if not recognized, will reject the user asking them to "upgrade"
their browser.

This affects all non-netscape Gecko-based browsers.  Netscapes 6.x and 7.x are
supposedly supported, so there is no reason why Mozilla browsers should not also
be supported.  The solution is very simple - change the browser detect script to
detect non-Netscape browsers.

So far a request to their support email address have been answered with a "we
value your suggestions into how we can improve our website" form letter.  Have
been told that "if you cannot run Internet Explorer or Netscape then we will be
happy to promptly refund your money".  

Need to find a better address/contact to send requests for a fix to.

Comment 3

14 years ago
Isn't this a dupe of bug 165257?

Comment 4

14 years ago
indeed, it is a dup of bug #165257

*** This bug has been marked as a duplicate of 165257 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.