100% CPU when viewing source at tvguide.com/listings

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Greg Campbell, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030823 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030823 Mozilla Firebird/0.6.1+

When viewing the source at http://www.tvguide.com/listings/, CPU usage goes up
to 100% for a long time.  The page itself is rather slow to finish rendering also.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.tvguide.com/listings (pick a tv provider if cookies are unset)
2. Wait for the page to finish loading.
3. View the source.


Actual Results:  
100% CPU usage

Expected Results:  
Nothing out of the ordinary.

This might be Layout: tables (seems like that might be causing the slowness in
page loading), but I can't be sure if that's related to view source.

Comment 1

15 years ago
WFM Win2k Gecko/20030821 Mozilla Firebird/0.6.1+

Comment 2

15 years ago
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030813
(Mozilla CVS trunk build)

Comment 3

15 years ago
I get 100% CPU for a couple seconds. The page is also taking about 20% just by
being open.

WinNT Moz 2003082704.
Viewing the page, resulted in CPU-usage jumping to 26%, then to 13%, then to 0%.
With a two-second update-interval.

View-Source gave me 86% CPU-usage for 2 seconds, and then down to 0%.

WinXP SP1 trunk 2003082505.

Comment 5

15 years ago
Sounds like perhaps one of the ads is an animated GIF.  Some of those can cause
excessive CPU usage, especially on nVidia cards.   Try to narrow it down...
(Reporter)

Comment 6

15 years ago
Site was redesigned, no longer seems to be a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.