If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Long non-ASCII name breaks 'From:' field in mail header into TWO lines

RESOLVED INVALID

Status

MailNews Core
Internationalization
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Wonyong Koh, Assigned: smontagu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

If a Korean user name specified in Identity is longer than 21 bytes, the 'From:'
field in mail header is broken into two lines as:

>From - Wed Aug 27 23:40:29 2003
>X-Mozilla-Status: 0001
>X-Mozilla-Status2: 00000000
>FCC: mailbox://xxx@xxxx.xxx/Sent
>X-Identity-Key: id2
>Date: Wed, 27 Aug 2003 23:40:29 +0900
>From: =?EUC-KR?B?sKEzNDU2Nzg5MDEyMzQ1Njc4OTAxMg==?=
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> <xxx@xxxx.xxx>
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>X-Mozilla-Draft-Info: internal/draft; vcard=0; receipt=0; uuencode=0
>User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
>X-Accept-Language: en-us, en
>MIME-Version: 1.0
>To:  xxx@xxxx.xxx
>Subject: test
>Content-Type: text/html; charset=EUC-KR
>Content-Transfer-Encoding: 8bit

The 'From:' field does not break into two lines if the name including Korean
character code is upto 21 bytes long. This problem does not show up if the name
include only ASCII characters. ('From:' field remains as one line even with
100-byte-long ASCII name.)

The 'From:' should remain as one line with whatever name, isn't it? I cannot
send email through a SMTP server which seems to find user name in the first line
instead of the true user name <xxx@xxxx.xxx> in the second line. I cannot blame
the SMTP server.


Reproducible: Always

Steps to Reproduce:
1. Go to menu 'Edit' -> 'Mail & Newsgroups Account Settings...'.
2. Enter '&#44032;34567890123456789012' in 'Your Name:' field in 'Identity'.
3. Click 'OK'.
4. Compose a message and 'Save As' 'Draft'.
5. Go to 'Draft' folder.
6. Look at the mail header of just save message via 'View' 'Message Source' menu
or simply by pressing Ctrl+U.

Actual Results:  
'From:' field in mail header consists of TWO lines.

Expected Results:  
'From:' filed should remain as ONE line.
(Reporter)

Comment 1

14 years ago
The string in the 2nd step to reproduce does not appear as I meant.

> 2. Enter '&#44032;34567890123456789012' in 'Your Name:' field in 'Identity'.

Please Enter '1234567890123456789012' and replace the first '12' (or any two
digits) with an Korean character which is an 16-bit code.
(Assignee)

Comment 2

14 years ago
I think our behaviour is correct according to RFC 2047. IMHO you *can* blame the
SMTP server.

This isn't specific to Korean, by the way.
Summary: Long Korean name breaks 'From:' field in mail header into TWO lines → Long non-ASCII name breaks 'From:' field in mail header into TWO lines

Comment 3

14 years ago
I agree with Simon that your SMTP server IS to blame. What smtp server do you use?

BTW, I guess we're wrapping lines a bit too prematurely (although there's
nothing wrong with it)

As for entering a Korean (or any other non-ascii) string in bugzilla, make sure
to set View|Character Coding to UTF-8 before typing your comment. 
(Assignee)

Comment 4

14 years ago
Resolving INVALID, since Jungshik, biesi (on IRC) and I are all in agreement.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.