font preference UI behavior inefficient - seeing multiple encoding's settings

RESOLVED DUPLICATE of bug 217523

Status

RESOLVED DUPLICATE of bug 217523
15 years ago
14 years ago

People

(Reporter: dsb, Assigned: bugs)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.79 [en] (X11; U; Linux 2.4.18+dsb+smp+ide i686)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030718

The UI design for font preferences is inefficient--seeing the settings for
multiple encodings require sequentially selecting them one at a time.

Additionally, the user can't see multiple sets of settings at the same
time (e.g., to compare corresponding settings).


Perhaps some other UI design would allow viewing multiple encodings' settings
at once at once without making changing the settings much harder.

Maybe some kind of expandable/collapsible two-level list would work, e.g.:

+ Western:
  +-------------------+
  | current pane of   |
  | UI controls       |
  |                   |
  +-------------------+
+ Unicode:
  +-------------------+
  | current pane of   |
  | UI controls       |
  |                   |
  +-------------------+
etc...

where the "+" characters indicate expand/collapse buttons.


Another possibility is a tabbed pane with some mechanism for opening
multiple windows; perhaps right-clicking on a tab opens a new window.
This still requires a user action for each encoding in the list, but
at least it would allow seeing multiple settings at once (and would
allow jumping back and forth between changing settings for one
encoding and or a second by justing shifting between windows).

Reproducible: Always

Steps to Reproduce:
Try to compare the 9 settings for one encoding with the 9 settings
for some other encoding.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 217523 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.