web links in Firefox UI should use current window

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Jeremy M. Dolan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030824 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030824 Mozilla Firebird/0.6.1+

Links to web pages embeded in Firebird's UI unexpectedly cause a new
"sub-window" to be opened, of limited functionality. It is in no way clear to
users this is: 1) an additional window, 2) functionality is hindered because it
is a child of a modal dialog.

Reproducible: Always

Steps to Reproduce:
1. My friend, a person of above-average intelligence, a CS major, and an MSIE
user, is using my web browser.
2. Said friend has multiple tabs open.
3. Said friend clicks on "Get New Extensions" in the prefs window.

Actual Results:  
New window opens on top of the current window and prefs dialog, with the same
dimensions and look of a regular "browser". Said friend logically assumes the
browser just destroyed her other tabs to load this extension page and is quite
upset. (My desktop has no "window list" type bar, so by ALL indications, this is
exactly what has happened)

Expected Results:  
If links in the UI (Copyright and Contributor information, get new themes, get
new extensions, etc) must render a web page, either open a window of different
size and appearence (no menus/navigation elements), or reuse the current window.

PLEASE, hear me out: I know some users don't understand the Back button. But
those same users definitely aren't opening up Options under the Tools menu, much
less navigating to the extensions tab, and trying to install something.

At least under Linux, because of the nature of how this new "sub-window" is
opened, while browsing themes, extentions, or the contributor page, tabs and
content in your "real" browsing window are completely inaccessible. If anything
might confuse users, it's this. Not to mention that often I want to refer to
other web pages while browsing the extension page.

Also, there are some bugs cause by these "sub-windows" that would be "fixed"
when they are removed.
(Reporter)

Comment 1

14 years ago
Additionally, in todays builds, the links are plain black text, and there is no
indication they are loading when you click those. This leads to multiple clicks
before the first window opens, and given Mozilla's poor new window perf, the app
can lock up for 30-40 seconds trying to open 4-5 new windows to show the
extensions page.

Updated

14 years ago
QA Contact: asa
Is this an issue in Firefox 0.8?
Summary: web links in Firebird UI should use current window → web links in Firefox UI should use current window
(Reporter)

Comment 3

14 years ago
The added problem in comment 1 has un-regressed, but the original issue stands.

Comment 4

11 years ago
I have come across this problem while searching for GIMPshop. My first reaction was to ask why a woman would leave her guy using the same computer. I thought of those adult homepages and indeed that was the reason. And quite honestly I cannot understand that this is a reason to finish a long term relationship. Call me conservative, but if that was all he did wrong all those years and if every other important aspect of life was commonly shared between the two, why split up on the ground of suspicion. It is not clear what he did, so I would suggest an open discussion about it. Not only in his interest, but for both! I am sure he did not want her to know about it as he knew the consequences. But maybe there is a good reason why. Something might have been missing and in finding that you might end up in having move profound and happier relationship than ever before. That is a theory, but I think you should give it a shot. All the best to both of you!
Assignee: bross2 → nobody
QA Contact: general
Bug 263433 addressed most of these issues, AFAIK.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.