Last Comment Bug 217564 - Font not installed, and impossible to find font on server (or trying to download an undefined package)
: Font not installed, and impossible to find font on server (or trying to downl...
Status: RESOLVED INCOMPLETE
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Windows XP
: -- minor (vote)
: ---
Assigned To: Simon Montagu :smontagu
:
: Makoto Kato [:m_kato]
Mentors:
http://www.debian.org/distrib/packages
: 237444 312835 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-28 01:04 PDT by erik johansson
Modified: 2012-10-25 18:47 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
full screen window, 12 kb png (11.57 KB, image/png)
2003-08-28 16:47 PDT, Hermann Schwab
no flags Details
box, 4 kb (3.03 KB, image/png)
2003-08-28 16:48 PDT, Hermann Schwab
no flags Details

Description erik johansson 2003-08-28 01:04:47 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827

When I go to this page ( http://www.debian.org/distrib/packages ) I get a big
pop up[1] saying I should install korean, when I click to install the font it
tries to open a webpage[2] in mozilla, this webpage doesn't exists.

This error shows up for korean and simplified chines (and one more I can't
remmeber rightnow)

Further, There are lots of popups that says "... the following components:" and
then only list on component per popup. It would be alot nicer if they used the
same popup.. 

[1] The poopup fills the whole screen 
[2] http://www.mozilla.org/projects/intl/fonts/win/redirect/package_undefined.html


Reproducible: Always

Steps to Reproduce:
1. Fresh mozila install (important some bugs goes a away if it is not *FRESH*)
2. go to http://www.debian.org/distrib/packages With *newly* installed mozilla
3. Try to install the font

Actual Results:  
step 2. you will get a BIG popup
step 3. you will come to a webpage which is basically a 404.

Expected Results:  
Installed the font Magically.. ;-) (actually I don't need this

Not very related to: 84951 where mozilla says that it can't install Korean Font,
just in the same category.
Comment 1 Simon Montagu :smontagu 2003-08-28 13:24:47 PDT
Confirming. I'm not sure if it's related, but I get a lot of this as well:

###!!! ASSERTION: no xul:window: 'windowElement', file
c:/MozillaWork/shaping1/mozilla/xpfe/appshell/src/nsXULWindow.cpp, line 983
Comment 2 Hermann Schwab 2003-08-28 16:47:25 PDT
Created attachment 130573 [details]
full screen window, 12 kb png

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030828

installed 1.5b ontop of my normal mozilla directory for trunk, normal profile,
ok.

installed 1.5b in a new directory, new profile, seeing this bug.
repeated start of browser, changing preferences, default browser,
then after some tries all was working, but the first tries I saw the error in
different kinds.

installed Nightly ontop of my normal mozilla directory for trunk, i.e. over
1.5b, and selected my normal profile again, browser starts:

QA->bugs filed today
opening bug 217564
open debian in a new tab, loading in the background:

three untitled fullscreen windows are popping up, and then the Dialog Box for
font download, normal size, on the full screen background of the previous
window

Javascript console shows 35 times the same text:
Warning: reference to undefined property this.mPanelContainer
Source File: chrome://global/content/bindings/tabbrowser.xml
Line: 1398

The 'full screen window' is the box, rendered top left, without title bar
'Download Font', without font spec 'Korean Text Display', and without size '2.1
MB'

I´ve got five icons in my windows status bar:
1st shows Mozilla icon and holds Bug 217654 in one tab nd Debian in another.
next three are empty, only background colour, holding the 'full screen windows'

5th shows Mozilla icon and holds the download box.

clicking on the download button in a fullscreen window goes to following URL:
http://www.mozilla.org/projects/intl/fonts/win/redirect/package_undefined.html
Seems to be normal, as the package is not seen in the fullscreen window.
Comment 3 Hermann Schwab 2003-08-28 16:48:13 PDT
Created attachment 130574 [details]
box, 4 kb
Comment 4 Daniel Wang 2004-04-21 10:12:42 PDT
*** Bug 237444 has been marked as a duplicate of this bug. ***
Comment 5 Adam Hauner 2005-10-19 02:44:42 PDT
*** Bug 312835 has been marked as a duplicate of this bug. ***
Comment 6 Andre Klapper 2011-11-13 10:11:39 PST
I don't have a Windows machine so I cannot test this myself...
Does this problem still happen for you in a recent version, or can this be closed as obsolete nowadays?
If it still happens: Which exact version still has this problem, and which operating system (Windows, Mac OS, Linux, ...) and version do you use?
Comment 7 Andre Klapper 2012-10-25 18:47:40 PDT
Unfortunately closing this report as no further information has been provided.

Please feel free to reopen this report if you can provide the information asked for and if this still happens in a recent and supported version. Thanks!

Note You need to log in before you can comment on or make changes to this bug.