If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

menu and page fonts are not anti-aliased

RESOLVED INVALID

Status

()

Core
Layout: Text
--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Ricky Ng-Adam, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030827

on same Redhat 9/KDE

Mozilla 1.4: nice fonts 
Mozilla 1.5beta: horrible fonts

I'll try to attach screenshots (can we put attachment here?)

Reproducible: Always

Steps to Reproduce:
1. install mozilla-1.5beta on RH9
2. launch mozilla
3. open mouth at how horrible the fonts look like

Actual Results:  
horrible looking fonts

Expected Results:  
have nice fonts on RH9 at all time and between all release of the browser
(Reporter)

Comment 1

14 years ago
Created attachment 130520 [details]
screenshot of Mozilla 1.4 on RH9
(Reporter)

Comment 2

14 years ago
Created attachment 130521 [details]
screenshot of Mozilla 1.5beta on RH9

Comment 3

14 years ago
Were you using the 1.4 rpms from Redhat? You need Mozilla builds with XFT
enabled to see the AA fonts by default. At the moment I can't seem to find any
XFT enabled 1.5b builds but here's what you can do to improve the fonts in a
non-xft build.

In your profile diretcory, open up user.js (create it if it isn't there) and add
the following lines

//enable freetype
user_pref("font.FreeType2.enable", true);
user_pref("font.FreeType2.unhinted", false);

// set the fonts directory
user_pref("font.directory.truetype.1", "<path-to-truetype-fonts>")

Restart Mozilla and it should be fine. If it isn't try adding teh following
lines in your userChrome.css file located in <profile-dir>/chrome. Again, create
the file if it doesn't exist.

menubar, menubutton, menulist, menu, menuitem, textbox, toolbar, tab,
tree, tooltip
{
	font-family: verdana, helvetica !important;
	font-size: 11px !important;
}
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

14 years ago
Ok, thanks for taking the time at looking at this. Wouldn't it be possible to
mention it in the known issues? I read  "Mozilla does not support Dynamic
Fonts", but something such as "Fonts won't be anti-aliased except with XFT
build".  I'm willing to test, but decent fonts is such a basic thing that it
doesn't make sense without a xft build.

I tried your tip but I'm because of the '<path-to-truetype-fonts>' for the
'font.directory.truetype.1';  I didn't seem to have any of those kind of .ttf
files and from my googling it seems to require a download of the package from
Microsoft (!).

There is a page here that had instructions similar to what you told me

http://ozzzy.dyndns.org/mandrake/mozilla.html

So I used it and installed the RPM from there. but the result are not much
better (see attachment that I will put up after posting this).

So I'll wait until rawhide has them or someone else makes an XFT build. 

In case anyone else wants 1.5 with XFT, here is the link to where I had found
1.4 with XFT (you were right, I had forgotten that I picked 1.4 from there and
they haven't made 1.5b available yet):

http://rawhide.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/
(Reporter)

Comment 5

14 years ago
Created attachment 130579 [details]
screenshot of Mozilla 1.5beta after fiddling with it
You need to log in before you can comment on or make changes to this bug.