infinite loop in chatzilla when replaying dircproxy logs

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
critical
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Gerhard Häring, Assigned: Robert Ginda)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827

I use dircproxy as an IRC proxy and have set it up to replay any messages I have
missed since I logged off. So when I log on again, it automatically reopens any
channels I were in and writes the last n messages in these channels, where n is
configurable in dircproxy.

Now this worked perfectly fine with the Chatzilla in Mozilla 1.4, but with 1.5
beta, all I get is:

[INFO] You are already connected to mylene.ghaering.de
[INFO] You are already connected to mylene.ghaering.de
[INFO] You are already connected to mylene.ghaering.de
[INFO] You are already connected to mylene.ghaering.de

etc. in what seems to be an infinite loop and Mozilla eats up all CPU resources.
Only thing that helps is killing it via the task manager.



Reproducible: Always

Steps to Reproduce:
1. use dircproxy as your IRC server
2. connect Chatzilla to dircproxy, join a few channels, then log off
3. wait a while, then log on again

Actual Results:  
See subject

Expected Results:  
play back the missed messages from the channels

This is my complete dircproxy configuration file (.dircproxyrc). Obviously, I
removed the password. As you see, it's all dircproxy defaults except the one
connection I defined:

connection {
    password "[censored]"
    server "splatterworld.de.quakenet.org:6668"
    join "#[tdw]"
    detach_nickname "TDW-Cartman|off"
}

It's quite probable that this problem will occur with other bouncers/IRC proxies
as well and is not particular to the dircproxy server.
Severity: blocker → major

Updated

15 years ago
Severity: major → critical
Keywords: hang
(Assignee)

Comment 1

15 years ago
this is fixed in the latest chatzilla at
http://www.hacksrus.com/~ginda/chatzilla/ , and will be checked in shortly.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 2

14 years ago
Marking FIXED as per comments. If this is not true, please reopen.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.