Most links behave correctly when hovered, yet some do not show the underline (as specified in the style sheet).

RESOLVED DUPLICATE of bug 196249

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 196249
15 years ago
15 years ago

People

(Reporter: josh roulston, Assigned: saari (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030828
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030828

It seems that most links are fine yet a few (sam & max, cornettos at the time of
posting this bug) do not hover correctly. I also found that when I select the
text - the content in which these links are - those links that do not hover
properly and the italic text does not show up as selected. I copied and pasted
the text into a text editor and it copied and pasted as if it was selected yet
didn't show up as being selected. I don't know if that's related.

I also previously had a problem with mozilla 1.4 in which some links (on this
same page) would expand when hovering over them so 'link' would turn into
'link_link_link' when the mouse moved over and then 'link_link_link_link_link'
when the mouse moved off. this would continue as each mouse over and off
happened and the text would scroll off the screen.

i'm not sure if there's anything strange in the source or that i've coded my web
page badly but either way, it shouldn't be doing either of these bugs - there's
no javascript to be doing anything like this. i'm wondering if maybe this
secondary bug (which doesn't happen in 1.5) is in anyway related to the current bug.

Reproducible: Always

Steps to Reproduce:
1. go to http://paradroid.com/
2. move mouse over links until underline doesn't appear
3. "there is no step three" - Jeff Goldblum

Actual Results:  
no underline on sam & max or cornettos

Expected Results:  
shown an underline under sam & max and cornettos

i haven't seen this bug anywhere else so i'm really sorry if i'm doing something
stupid. i love the mozilla browser and i'm really grateful for it. keep up the
good work.

Comment 1

15 years ago
Bug 191751 Text link mouseover causes text link to replicate inside document.
is a dupe of Bug 177539 where you can find lot´s of dupes.

Bug 196249 hover effect intermittent at tigerdirect.com
seems to describe the behaviour of your links.

Bug 196249 comment 1 cites the CSS 2 spec:
 A:hover must be placed after the A:link and A:visited rules

from http://paradroid.com/style_sheet.css

a:hover {
	text-decoration: underline;
}

a:visited {
	color: #bf5f00;

}

If changing the sequence of these rules fixes the bug, please report back here.
I don´t know, if this is right or wrong, I´m just reading bugs, not specs,
I´m not a web designer/programmer.

to your links:
when I first loaded the website, and reload didn´t change anything,
sam&max, a small slice of raw satirical commentary, digicam weren´t underlined,
cornetto was.
Then I worked on the bug, looked at a lot of links in many tabs, put a lot of
text over here, and forgot to send, just closed the tabs.
So I repeated the search, loaded the site again, and this time cornetto wasn´t
underlined, but digicam was.
	 

*** This bug has been marked as a duplicate of 196249 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
I did a download, and could see the bug loading locally.
Then I renamed the style_sheet.css to style_sheet.err, made a copy as
style_sheet.ok, edited stylesheet.ok that the sequence of a.hover and a.visited
was reversed.
renaming *.ok to *.css and reloading the file was showing all links ok,
renaming *.err to *.css and reloading showed previous error.
I repeated this a couple of times, this fixed the bug.
You need to log in before you can comment on or make changes to this bug.