[Webshell Print] [CRASH] Crash printing infoseek.com page

VERIFIED DUPLICATE of bug 21470

Status

()

Core
Printing: Output
P3
critical
VERIFIED DUPLICATE of bug 21470
18 years ago
18 years ago

People

(Reporter: shrirang khanzode, Assigned: dcone (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I used today's commercial build on windows.
Launched " www.infoseek.com".
After the page loaded, used the "File|Print" menu option to print the page.
The browser crashed with following trace. Also saw this problem on MAC.

 Trigger Type:  Program Crash

 Trigger Reason:  Access violation

 Call Stack:    (Signature = nsWebShell::Destroy a72c74ad)

   nsWebShell::Destroy

[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 3809]

   nsGfxTextControlFrame::~nsGfxTextControlFrame

[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsGfxTextControlFrame.cpp,
line 301]

   nsGfxTextControlFrame::`scalar deleting
   destructor'


   nsFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, line 412]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsLineBox::DeleteLineList

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 233]

   nsBlockFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1125]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsTableFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 247]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsLineBox::DeleteLineList

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 233]

   nsBlockFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1125]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsTableFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 247]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsLineBox::DeleteLineList

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 233]

   nsBlockFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1125]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsTableFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 247]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsLineBox::DeleteLineList

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 233]

   nsBlockFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1125]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsTableFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 247]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]

   nsContainerFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 97]

   nsLineBox::DeleteLineList

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 233]

   nsBlockFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1125]

   nsLineBox::DeleteLineList

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 233]

   nsBlockFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1125]

   nsAreaFrame::Destroy

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsAreaFrame.cpp, line 70]

   nsFrameList::DestroyFrames

[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 35]


 Registers:
 EAX:
      00000000
                     EBX:
                          00000000
                                         ECX:
                                              028e6d90
                                                             EDX:
                                                                  00301aac
 ESI:
      028e6d90
                     EDI:
                          00000000
                                         ESP:
                                              0012f6c8
                                                             EBP:
                                                                  0012f730
 EIP:
      60968148
                     cf PF af ZF sf of IF df nt RF vm   IOPL: 0

 CS:
     001b
             DS:
                0023
                        SS:
                            0023
                                    ES:
                                       0023
                                               FS:
                                                   0038
                                                           GS:
                                                              0000

Updated

18 years ago
Severity: major → critical
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: [CRASH] Crash printing infoseek.com page → [Print Fail CRASH] Crash printing infoseek.com page
(Assignee)

Updated

18 years ago
Target Milestone: M13
(Assignee)

Updated

18 years ago
Summary: [Print Fail CRASH] Crash printing infoseek.com page → [Webshell Print [CRASH] Crash printing infoseek.com page
(Assignee)

Updated

18 years ago
Summary: [Webshell Print [CRASH] Crash printing infoseek.com page → [Webshell Print] [CRASH] Crash printing infoseek.com page
(Assignee)

Comment 1

18 years ago
This is a webshell problem
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

18 years ago
GFXTextControlFrame is trying to get the parents Webshell.. and an assert is
hit.  This is the same as 21470

*** This bug has been marked as a duplicate of 21470 ***
(Reporter)

Comment 3

18 years ago
verified as duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.