If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla crashes on startup.

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Sunil, Unassigned)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5a) Gecko/20030527
Build Identifier: ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla1.4/src/mozilla-source-1.4.tar.gz

Built mozilla with config:

-----------------------------------------------------------
./configure  --prefix=/home/sukumar/garnome --exec_prefix=/home/sukumar/garnome
--bindir=/home/sukumar/garnome/bin --sbindir=/home/sukumar/garnome/sbin
--libexecdir=/home/sukumar/garnome/libexec --datadir=/home/sukumar/garnome/share
--sysconfdir=/home/sukumar/garnome/etc
--sharedstatedir=/home/sukumar/garnome/share
--localstatedir=/home/sukumar/garnome/var --libdir=/home/sukumar/garnome/lib
--infodir=/home/sukumar/garnome/info --includedir=/home/sukumar/garnome/include
--mandir=/home/sukumar/garnome/man --enable-default-toolkit=gtk2
--disable-gtktest --enable-calendar --enable-mailnews --disable-freetypetest
--enable-xft --enable-crypto --disable-jsd --enable-xinerama --enable-composer
--enable-mathml --disable-installer --disable-tests --disable-debug
--enable-optimize=-O2 --disable-dtd-debug --disable-pedantic --disable-glibtest
--with-system-zlib --disable-static --disable-gtk-doc --disable-libIDLtest

-----------------------------------------------

on solaris 2.6. Compile warnings:

----------------------------------
Undefined                       first referenced
 symbol                             in file
NSGetFactory                       
../../../../build/unix/gnu-ld-scripts/components-mapfile
NSUnregisterSelf                   
../../../../build/unix/gnu-ld-scripts/components-mapfile
NSRegisterSelf                     
../../../../build/unix/gnu-ld-scripts/components-mapfile
ld: warning: Symbol referencing errors
chmod +x libfileview.so
----------------------------------

No build errors or warnings.

No existing mozilla install in /home/sukumar. No /home/sukumar/.mozilla directory.

Mozilla aborts with this on the top of the stack trace:

--------------------------------------
#0  0xed701a88 in  
_ZN15imgContainerGIF16DecodingCompleteEv ()   from
/private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
--------------------------------------

I built with Xft disabled => same results.

Reproducible: Always

Steps to Reproduce:
1. Steps are mentioned above.
2.
3.

Actual Results:  
Mozilla crashed. Sometimes it showed the outline of the window for profile
selection and abort immd.

Expected Results:  
Mozilla should not abort.

How can I upload the core file if you need it?
(Reporter)

Comment 1

14 years ago
Detailed stack:

---------------------

[New LWP 6]
[New LWP 7]

Program received signal SIGSEGV, Segmentation fault.
0xed6b1aa4 in _ZN15imgContainerGIF16DecodingCompleteEv () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
(gdb) bt
#0  0xed6b1aa4 in _ZN15imgContainerGIF16DecodingCompleteEv () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
#1  0xed6b0b74 in _ZN13nsGIFDecoder26EndGIFEPvi () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
#2  0xed6afe18 in _Z9gif_writeP10gif_structPKhj () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
#3  0xed6b0a18 in _ZN13nsGIFDecoder211ProcessDataEPhjPj () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
#4  0xed6b0828 in _Z11ReadDataOutP14nsIInputStreamPvPKcjjPj () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
#5  0xedf07104 in
_ZN17nsPipeInputStream12ReadSegmentsEPFjP14nsIInputStreamPvPKcjjPjES2_jS5_ ()
from /home/sukumar/garnome/lib/mozilla-1.4/libxpcom.so
#6  0xed6b0a68 in _ZN13nsGIFDecoder29WriteFromEP14nsIInputStreamjPj () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
#7  0xed6ac130 in
_ZN10imgRequest15OnDataAvailableEP10nsIRequestP11nsISupportsP14nsIInputStreamjj
() from /private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
#8  0xed6a9e94 in
_ZN13ProxyListener15OnDataAvailableEP10nsIRequestP11nsISupportsP14nsIInputStreamjj
() from /private/sukumar/garnome/lib/mozilla-1.4/components/libimglib2.so
#9  0xede2c848 in
_ZN12nsJARChannel15OnDataAvailableEP10nsIRequestP11nsISupportsP14nsIInputStreamjj
() from /private/sukumar/garnome/lib/mozilla-1.4/components/libnecko.so
#10 0xeddaa240 in _ZN17nsInputStreamPump15OnStateTransferEv () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libnecko.so
#11 0xeddaa020 in
_ZN17nsInputStreamPump18OnInputStreamReadyEP19nsIAsyncInputStream () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libnecko.so
#12 0xedf57ed4 in ?? () from /home/sukumar/garnome/lib/mozilla-1.4/libxpcom.so
#13 0xedf1f664 in PL_HandleEvent () from
/home/sukumar/garnome/lib/mozilla-1.4/libxpcom.so
#14 0xedf1f598 in PL_ProcessPendingEvents () from
/home/sukumar/garnome/lib/mozilla-1.4/libxpcom.so
#15 0xedf20668 in _ZN16nsEventQueueImpl20ProcessPendingEventsEv () from
/home/sukumar/garnome/lib/mozilla-1.4/libxpcom.so
#16 0xed5d4b00 in _Z24event_processor_callbackP11_GIOChannel12GIOConditionPv ()
from /private/sukumar/garnome/lib/mozilla-1.4/components/libwidget_gtk2.so
#17 0xef0d1044 in g_io_unix_dispatch () from
/home/sukumar/garnome/lib/libglib-2.0.so.0
#18 0xef0aba6c in g_main_dispatch () from /home/sukumar/garnome/lib/libglib-2.0.so.0
#19 0xef0ace08 in g_main_context_dispatch () from
/home/sukumar/garnome/lib/libglib-2.0.so.0
#20 0xef0ad19c in g_main_context_iterate () from
/home/sukumar/garnome/lib/libglib-2.0.so.0
#21 0xef0ad460 in g_main_context_iteration () from
/home/sukumar/garnome/lib/libglib-2.0.so.0
#22 0xed5d548c in _ZN10nsAppShell19DispatchNativeEventEiPv () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libwidget_gtk2.so
#23 0xed61d100 in _ZN11nsXULWindow9ShowModalEv () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libnsappshell.so
#24 0xed61aff4 in _ZN18nsContentTreeOwner11ShowAsModalEv () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libnsappshell.so
#25 0xee88b384 in
_ZN15nsWindowWatcher12OpenWindowJSEP12nsIDOMWindowPKcS3_S3_ijPlPS1_ () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libembedcomponents.so
#26 0xee88a6f8 in
_ZN15nsWindowWatcher10OpenWindowEP12nsIDOMWindowPKcS3_S3_P11nsISupportsPS1_ ()
from /private/sukumar/garnome/lib/mozilla-1.4/components/libembedcomponents.so
#27 0xed546d2c in _ZN9nsProfile21LoadDefaultProfileDirER9nsCStringi () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libprofile.so
#28 0xed546288 in _ZN9nsProfile15StartupWithArgsEP17nsICmdLineServicei () from
/private/sukumar/garnome/lib/mozilla-1.4/components/libprofile.so
#29 0xed622800 in _ZN17nsAppShellService16DoProfileStartupEP17nsICmdLineServicei
() from /private/sukumar/garnome/lib/mozilla-1.4/components/libnsappshell.so
#30 0x1e6e4 in _Z24InitializeProfileServiceP17nsICmdLineService ()
#31 0x1f2bc in _Z5main1iPPcP11nsISupports ()
#32 0x1fd4c in main ()
(gdb)
-------------------------------

Comment 2

14 years ago
Reporter:
Which compiler do you use ?
OS: SunOS → Solaris
(Reporter)

Comment 3

14 years ago
gcc 3.3.1.

This problem went away after I compiled imgContainerGIF.cpp with -g flag instead
of -O2. Weird! Then, I built the whole thing with -O.

But I hit another crash. When I open the mail window(after all the setup), it
says connecting to server, sending login information and that's it. No prompting
for password, no fetching of mails. After sometime(a minute or so), mozilla will
crash. When run thru GDB I found that it crashes in PasswordPrompt function. I
notice that mozilla is not able to throw open any kind of dialog boxes, not even
ones from buttons in the page like in hotmail, to empty the Junk Mail folder if
I click on the button, nothing happens, it should ask for confirmation OR if I
right click on a link and ask to "save target as .." nothing happens, it should
throw open file selector dialog. If I start mozilla without a profile name,
pressing "start mozilla" button doesn't do anything in the profile selector, so
I have to start with -P.

If I don't open mail window, mozilla doesn't crash, but all dialog boxes don't
show up. All this happens whether Popups are enabled or not.

So, looks like something is really messed up with either GTK2(version installed
is 2.2.3 = LATEST) or mozilla 1.4 on solaris. With or without XFT, same results.
(Reporter)

Comment 4

14 years ago
1.4 is a pile of junk, I think.

1.5b doesn't have any of these issues. So, anybody coming here with similar
issues, I would say get 1.5b. Its much more stable than the "supposedly stable 1.4".
(Reporter)

Comment 5

14 years ago
Marking fixed in 1.5b
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 6

14 years ago
Not FIXED.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 7

14 years ago
-> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.