On HTTPS pages with a single submit button, hitting enter hangs mozilla (until user intervention)

RESOLVED DUPLICATE of bug 217651

Status

()

Core
HTML: Form Submission
RESOLVED DUPLICATE of bug 217651
15 years ago
15 years ago

People

(Reporter: resigned, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

What appears to be happening is that when the protocol in the URL address is
"https" (note: http-over-SSL. Not ordinary http) and there is a single submit
button on the page, hitting Enter does NOT submit the form - HOWEVER Mozilla
goes "busy" with the "loading page animation" going in the top right corner.

Looking at traffic on the network, and attaching a debugger to the https server
(port 443), I can confirm that mozilla appears to send NO PACKETS to the Https
server. I don't have a full packet sniffer, so I can't prove that no packets are
sent at all - perhaps they are sent to the wrong address? - but my hub etc show
no activity.

If you actually CLICK on the button with your mouse, the page submits as
expected, no problems at all. I don't know whether the CORRECT behaviour would
be that "mozilla does nothing" or "mozilla submits the form" - but at the moment
it is APPEARING to submit the form, whilst actually doing nothing.

(the example I use is a login page, with name + password fields - for relevant
highlights from HTML source, see steps to reproduce)

Reproducible: Always

Steps to Reproduce:
HTML source for the button (note: this works perfectly if I serve the file over
HTTP, OR if I click on the button - it's just over https, hitting enter, that
things go wrong)..

<form action="https://myserver/login" method="post">
   <input type="submit" name="submit" value="login">Login</input>
</form>
submitting once is enough !

*** This bug has been marked as a duplicate of 217651 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.