On HTTPS pages with a single submit button, hitting enter hangs mozilla (until user intervention)

RESOLVED INVALID

Status

()

Core
HTML: Form Submission
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: resigned, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

What appears to be happening is that when the protocol in the URL address is
"https" (note: http-over-SSL. Not ordinary http) and there is a single submit
button on the page, hitting Enter does NOT submit the form - HOWEVER Mozilla
goes "busy" with the "loading page animation" going in the top right corner.

Looking at traffic on the network, and attaching a debugger to the https server
(port 443), I can confirm that mozilla appears to send NO PACKETS to the Https
server. I don't have a full packet sniffer, so I can't prove that no packets are
sent at all - perhaps they are sent to the wrong address? - but my hub etc show
no activity.

If you actually CLICK on the button with your mouse, the page submits as
expected, no problems at all. I don't know whether the CORRECT behaviour would
be that "mozilla does nothing" or "mozilla submits the form" - but at the moment
it is APPEARING to submit the form, whilst actually doing nothing.

(the example I use is a login page, with name + password fields - for relevant
highlights from HTML source, see steps to reproduce)

Reproducible: Always

Steps to Reproduce:
HTML source for the button (note: this works perfectly if I serve the file over
HTTP, OR if I click on the button - it's just over https, hitting enter, that
things go wrong)..

<form action="https://myserver/login" method="post">
   <input type="submit" name="submit" value="login">Login</input>
</form>
*** Bug 217648 has been marked as a duplicate of this bug. ***
*** Bug 217649 has been marked as a duplicate of this bug. ***
>rv:1.3) Gecko/20030312

Sorry but we accept only bugs from the latest milestone and that is 1.5b.
Please reopen if you see this with 1.5b
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

15 years ago
I would be using 1.4 at the very least, but you guys don't have a fully working
version of 1.4 released yet!!!

(see other bug reports if interested for info on the significant number of
people who, like me, are "stuck" at 1.3.... I have a full install of 1.4, having
followed all instructions etc, but am awaiting movement on the install bugs that
mean I can't actually start it up without crashes and hangs.)

re: "accept only bugs from the latest milestone"...

...Either this is a bug that's already been fixed. Or it's not. If the former,
it should be pretty darn easy to discover (it ought to be in the fixed-bugs
list, and if you can point me to a comprehensive such list, I'll have a look. I
can never find such a list whenever I look, or I would already have checked).

If it hasn't already been fixed, then you should leave it open in case someone
else has the time / opportunity to see if they get the same behaviour on later
builds.

However, your pathetic attitude has finally pushed me to revoke my BZ id, and to
 stop attempting to help in the dev process at all. Over the last few years,
there's been a marked change from when people used to respond sensibly and
constructively (albeit sometimes arrogantly and/or sarcastically - fair enough).
But I'm fed up with idiots like you who just take every attempt to help and
shove it down people's throats. You are the latest in a line of about 5 posters
I've seen make equally stupid remarks on people's bugs.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

15 years ago
> I would be using 1.4 at the very least, but you guys don't have a fully 
> working version of 1.4 released yet!!!

1.4 isn't the latest.  1.5b is.

> but am awaiting movement on the install bugs that mean I can't actually start 
> it up without crashes and hangs.

I know of no existing bug as you have described it.  What you're describing is
generally a problem with an install dir that has leftover files in it.

> if you can point me to a comprehensive such list, I'll have a look

http://bugzilla.mozilla.org/buglist.cgi?resolution=FIXED
there are 57600 fixed bugs.

> If it hasn't already been fixed, then you should leave it open in case someone
> else has the time / opportunity to see if they get the same behaviour on later
> builds.

the steps you have described are farily common and if other people saw this
problem, they would have reported it.  It works fine for me with 1.5b and 1.3

> But I'm fed up with idiots like you who just take every attempt to help

this bug is not helpful.  it is filed against a build that's about half a year
old.  There are plenty of problems we know exist in current Mozilla and it's
more productive to look at them (and find other bugs in current builds) than to
chase bugs in old builds.

if you want to be helpful, figure out why 1.4 (or 1.5b) isn't working for you.

resovling INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.